aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-Store-Cache
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-07-21 14:32:57 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-07-21 14:32:57 +0000
commit102dbe0ad0b9b8043c285243e356a55f4d72fa09 (patch)
tree8cd3fde93bc73e9b4819fb3ca519a31600952446 /www/p5-Catalyst-Plugin-Session-Store-Cache
parentc22df82ca0b43513bab99b68707fcb38e31fe270 (diff)
downloadports-102dbe0ad0b9b8043c285243e356a55f4d72fa09.tar.gz
ports-102dbe0ad0b9b8043c285243e356a55f4d72fa09.zip
This Catalyst plugin will store your session data in whatever cache module you
have configured.
Notes
Notes: svn path=/head/; revision=195989
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-Store-Cache')
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile30
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Cache/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-descr4
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-plist11
4 files changed, 48 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile
new file mode 100644
index 000000000000..82d549cd7e62
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-Cache
+# Date created: 21 Jul 2007
+# Whom: lbr@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-Cache
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Store sessions using a Catalyst::Plugin::Cache
+
+BUILD_DEPENDS= p5-Catalyst-Plugin-Session>=0.06:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+RUN_DEPENDS= p5-Catalyst-Plugin-Session>=0.06:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Session::Store::Cache.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Cache/distinfo b/www/p5-Catalyst-Plugin-Session-Store-Cache/distinfo
new file mode 100644
index 000000000000..e39ea77ef436
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Cache/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-Store-Cache-0.01.tar.gz) = edaca2c58c08314fa94878ff5a4fb14e
+SHA256 (Catalyst-Plugin-Session-Store-Cache-0.01.tar.gz) = d8ac902870fbe0916aba2b4cc9b3aa2f1a12c94ef704003cc9fb1fd6153d4112
+SIZE (Catalyst-Plugin-Session-Store-Cache-0.01.tar.gz) = 2181
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-descr b/www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-descr
new file mode 100644
index 000000000000..b75812705c29
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-descr
@@ -0,0 +1,4 @@
+This plugin will store your session data in whatever cache module you
+have configured.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-Cache/
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-plist b/www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-plist
new file mode 100644
index 000000000000..c58cf911bb7e
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Cache/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store/Cache/.packlist
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/Cache.pm
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Session/Store
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Session
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store/Cache
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst