aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Unicode
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-03-26 21:02:48 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-03-26 21:02:48 +0000
commita10f7721aec5d02b3ce60df205755ffc2ec5121b (patch)
tree9d3b2229babf924af10c810384dfc5f2947f6290 /www/p5-Catalyst-Plugin-Unicode
parentb2ce6e0e9da5b0e6227c98f2f8a11e5d365e93ab (diff)
downloadports-a10f7721aec5d02b3ce60df205755ffc2ec5121b.tar.gz
ports-a10f7721aec5d02b3ce60df205755ffc2ec5121b.zip
On request, decodes all params from UTF-8 octets into a sequence of
logical characters. On response, encodes body into UTF-8 octets. WWW: http://search.cpan.org/dist/Catalyst-Plugin-Unicode/ PR: ports/94951 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=158201
Diffstat (limited to 'www/p5-Catalyst-Plugin-Unicode')
-rw-r--r--www/p5-Catalyst-Plugin-Unicode/Makefile29
-rw-r--r--www/p5-Catalyst-Plugin-Unicode/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Unicode/pkg-descr4
-rw-r--r--www/p5-Catalyst-Plugin-Unicode/pkg-plist3
4 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Unicode/Makefile b/www/p5-Catalyst-Plugin-Unicode/Makefile
new file mode 100644
index 000000000000..3fd4f1397121
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Unicode/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Unicode
+# Date created: Mar 26, 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Unicode
+PORTVERSION= 0.2
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Unicode aware Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=0:${PORTSDIR}/www/p5-Catalyst
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Unicode.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Unicode/distinfo b/www/p5-Catalyst-Plugin-Unicode/distinfo
new file mode 100644
index 000000000000..bba93c41727c
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Unicode/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Unicode-0.2.tar.gz) = e95fbe438571b52661729b574d154f74
+SHA256 (Catalyst-Plugin-Unicode-0.2.tar.gz) = ed3a5e8a4d79e6c4c7f5c67c10abeb8cf93fc3cae8a6114026d552a34260baeb
+SIZE (Catalyst-Plugin-Unicode-0.2.tar.gz) = 2146
diff --git a/www/p5-Catalyst-Plugin-Unicode/pkg-descr b/www/p5-Catalyst-Plugin-Unicode/pkg-descr
new file mode 100644
index 000000000000..dec0d5f70910
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Unicode/pkg-descr
@@ -0,0 +1,4 @@
+On request, decodes all params from UTF-8 octets into a sequence of
+logical characters. On response, encodes body into UTF-8 octets.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Unicode/
diff --git a/www/p5-Catalyst-Plugin-Unicode/pkg-plist b/www/p5-Catalyst-Plugin-Unicode/pkg-plist
new file mode 100644
index 000000000000..1d67c9b1d3ab
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Unicode/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Catalyst/Plugin/Unicode.pm
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst