aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Display/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-10-24 10:33:31 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-10-24 10:33:31 +0000
commit8c1c9f3fbd9e37a3b6196d50af5b7b96184b3143 (patch)
tree813392c64a8083c7de99edea2776343de8526ad1 /www/p5-HTML-Display/Makefile
parent2688398134a8381ea0fb51145b9a052a39313b00 (diff)
downloadports-8c1c9f3fbd9e37a3b6196d50af5b7b96184b3143.tar.gz
ports-8c1c9f3fbd9e37a3b6196d50af5b7b96184b3143.zip
This module abstracts the task of displaying HTML to the user. The
displaying is done by launching a browser and navigating it to either a temporary file with the HTML stored in it, or, if possible, by pushing the HTML directly into the browser window. WWW: http://search.cpan.org/dist/HTML-Display/
Notes
Notes: svn path=/head/; revision=201905
Diffstat (limited to 'www/p5-HTML-Display/Makefile')
-rw-r--r--www/p5-HTML-Display/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/www/p5-HTML-Display/Makefile b/www/p5-HTML-Display/Makefile
new file mode 100644
index 000000000000..d252f288f3cf
--- /dev/null
+++ b/www/p5-HTML-Display/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-HTML-Display
+# Date created: 24 Oct 2007
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Display
+PORTVERSION= 0.39
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Display HTML locally in a browser
+
+RUN_DEPENDS= p5-HTML-TokeParser-Simple>=2:${PORTSDIR}/www/p5-HTML-TokeParser-Simple \
+ p5-libwww>=5.69:${PORTSDIR}/www/p5-libwww \
+ p5-parent>=0.218:${PORTSDIR}/devel/p5-parent \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
+ p5-Test-Harness>=2.30:${PORTSDIR}/devel/p5-Test-Harness
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Display.3 \
+ HTML::Display::Common.3 \
+ HTML::Display::Debian.3 \
+ HTML::Display::Dump.3 \
+ HTML::Display::Galeon.3 \
+ HTML::Display::Mozilla.3 \
+ HTML::Display::OSX.3 \
+ HTML::Display::Opera.3 \
+ HTML::Display::Phoenix.3 \
+ HTML::Display::TempFile.3 \
+ HTML::Display::Win32.3 \
+ HTML::Display::Win32::IE.3 \
+ HTML::Display::Win32::OLE.3
+
+.include <bsd.port.mk>