aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Field
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-25 19:26:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-25 19:26:19 +0000
commitd29f9efe58783bac0362f2c67f8b9670afabcf15 (patch)
tree25d2608697f7084906d66bf9c1849fae4b01a99e /www/p5-HTML-Field
parent5cc15f26ea5e6324ee569bde0dc305b26cf163d7 (diff)
downloadports-d29f9efe58783bac0362f2c67f8b9670afabcf15.tar.gz
ports-d29f9efe58783bac0362f2c67f8b9670afabcf15.zip
The HTML::Field set of modules creates objects that represent HTML form fields
which try to make it easier to interact with CGI objects, databases, and HTML::Template objects. The objective of an HTML::Field object is to know how to write its own HTML, how to get its value out of a CGI object or from a hash, how to add their value to a hash suitable for passing into a HTML::Template or into a SQL::Abstract object, for example, and thus re-use some of the code which is typically repeated several times in a CGI script. This bundle includes also HTML::FieldForm, which is a very simple module to manage sets of HTML::Field objects. WWW: http://search.cpan.org/dist/HTML-Field/ PR: ports/140982 Submitted by: Sahil Tandon <sahil at tandon.net>
Notes
Notes: svn path=/head/; revision=246626
Diffstat (limited to 'www/p5-HTML-Field')
-rw-r--r--www/p5-HTML-Field/Makefile22
-rw-r--r--www/p5-HTML-Field/distinfo3
-rw-r--r--www/p5-HTML-Field/pkg-descr14
-rw-r--r--www/p5-HTML-Field/pkg-plist6
4 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-HTML-Field/Makefile b/www/p5-HTML-Field/Makefile
new file mode 100644
index 000000000000..588c28e74c02
--- /dev/null
+++ b/www/p5-HTML-Field/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: HTML::Field
+# Date created: 28 November 2009
+# Whom: Sahil Tandon <sahil@tandon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Field
+PORTVERSION= 1.19
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sahil@tandon.net
+COMMENT= A perl module to generate HTML form elements
+
+MAN3= HTML::Field.3 \
+ HTML::FieldForm.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Field/distinfo b/www/p5-HTML-Field/distinfo
new file mode 100644
index 000000000000..166438031d34
--- /dev/null
+++ b/www/p5-HTML-Field/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Field-1.19.tar.gz) = 60d122a87239557711a4ca62d177a5a5
+SHA256 (HTML-Field-1.19.tar.gz) = 9b4ec3a463c8707b90ff2e4326f44fc062b6bc9683fb847b8fba5513957a4994
+SIZE (HTML-Field-1.19.tar.gz) = 19036
diff --git a/www/p5-HTML-Field/pkg-descr b/www/p5-HTML-Field/pkg-descr
new file mode 100644
index 000000000000..86450b526828
--- /dev/null
+++ b/www/p5-HTML-Field/pkg-descr
@@ -0,0 +1,14 @@
+The HTML::Field set of modules creates objects that represent HTML form fields
+which try to make it easier to interact with CGI objects, databases, and
+HTML::Template objects.
+
+The objective of an HTML::Field object is to know how to write its own HTML,
+how to get its value out of a CGI object or from a hash,
+how to add their value to a hash suitable for passing into a HTML::Template
+or into a SQL::Abstract object, for example, and thus re-use some of the code
+which is typically repeated several times in a CGI script.
+
+This bundle includes also HTML::FieldForm, which is a very simple module to
+manage sets of HTML::Field objects.
+
+WWW: http://search.cpan.org/dist/HTML-Field/
diff --git a/www/p5-HTML-Field/pkg-plist b/www/p5-HTML-Field/pkg-plist
new file mode 100644
index 000000000000..7492f25cc737
--- /dev/null
+++ b/www/p5-HTML-Field/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Field/.packlist
+%%SITE_PERL%%/HTML/Field.pm
+%%SITE_PERL%%/HTML/FieldForm.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Field
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML