aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Template-JIT
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2006-06-14 11:41:35 +0000
committerMathieu Arnold <mat@FreeBSD.org>2006-06-14 11:41:35 +0000
commit26f397025e1b976059ab25fb3fe2a97f64f0be04 (patch)
treeb20de2f7af6c24e75fec8aa55354eaf497e484d0 /www/p5-HTML-Template-JIT
parent8b4da4b206b0ae3ada80586f8adcf223cebaa11b (diff)
downloadports-26f397025e1b976059ab25fb3fe2a97f64f0be04.tar.gz
ports-26f397025e1b976059ab25fb3fe2a97f64f0be04.zip
Update to 0.05
PR: 98648 Submitted by: Rong-En Fan <rafan@infor.org>
Notes
Notes: svn path=/head/; revision=165396
Diffstat (limited to 'www/p5-HTML-Template-JIT')
-rw-r--r--www/p5-HTML-Template-JIT/Makefile7
-rw-r--r--www/p5-HTML-Template-JIT/distinfo6
-rw-r--r--www/p5-HTML-Template-JIT/files/patch-Compiler.pm11
-rw-r--r--www/p5-HTML-Template-JIT/files/patch-JIT::Base.pm11
-rw-r--r--www/p5-HTML-Template-JIT/files/patch-t::03loops.t22
-rw-r--r--www/p5-HTML-Template-JIT/files/patch-t::10escape.t22
6 files changed, 6 insertions, 73 deletions
diff --git a/www/p5-HTML-Template-JIT/Makefile b/www/p5-HTML-Template-JIT/Makefile
index 85a8aac7bfe7..dbb3079f7637 100644
--- a/www/p5-HTML-Template-JIT/Makefile
+++ b/www/p5-HTML-Template-JIT/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= HTML-Template-JIT
-PORTVERSION= 0.04
-PORTREVISION= 2
+PORTVERSION= 0.05
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -16,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
COMMENT= Perl module to compile HTML Templates with Inline::C
-BUILD_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+BUILD_DEPENDS= p5-HTML-Template>=2.8:${PORTSDIR}/www/p5-HTML-Template \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Inline/C.pm:${PORTSDIR}/devel/p5-Inline
+ p5-Inline>=0.43:${PORTSDIR}/devel/p5-Inline
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-HTML-Template-JIT/distinfo b/www/p5-HTML-Template-JIT/distinfo
index 2d8cfa23f09b..eb818c61111b 100644
--- a/www/p5-HTML-Template-JIT/distinfo
+++ b/www/p5-HTML-Template-JIT/distinfo
@@ -1,3 +1,3 @@
-MD5 (HTML-Template-JIT-0.04.tar.gz) = 5814cd407e3dcca9704188d7b1332b48
-SHA256 (HTML-Template-JIT-0.04.tar.gz) = 9c7e3a7be451b3e216364c24dccf205a2cef5b9df550c639998484f8f440c842
-SIZE (HTML-Template-JIT-0.04.tar.gz) = 28874
+MD5 (HTML-Template-JIT-0.05.tar.gz) = 6acac4deeabced6f684aab7ee4cc8b32
+SHA256 (HTML-Template-JIT-0.05.tar.gz) = a43601f70b28eef1ee99e7175efcb8925bc40b21d48b3b9ddd61f69513babca3
+SIZE (HTML-Template-JIT-0.05.tar.gz) = 30221
diff --git a/www/p5-HTML-Template-JIT/files/patch-Compiler.pm b/www/p5-HTML-Template-JIT/files/patch-Compiler.pm
deleted file mode 100644
index 70315eb7a2dd..000000000000
--- a/www/p5-HTML-Template-JIT/files/patch-Compiler.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- Compiler.pm.orig Tue May 18 18:32:59 2004
-+++ JIT/Compiler.pm Tue May 18 18:33:52 2004
-@@ -131,7 +131,7 @@
- SV * temp_sv;
- int i;
- STRLEN len;
-- char c;
-+ unsigned char c;
- char buf[4];
-
- SvPOK_on(result);
diff --git a/www/p5-HTML-Template-JIT/files/patch-JIT::Base.pm b/www/p5-HTML-Template-JIT/files/patch-JIT::Base.pm
deleted file mode 100644
index 22b99d125050..000000000000
--- a/www/p5-HTML-Template-JIT/files/patch-JIT::Base.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- JIT/Base.pm Wed Jun 9 15:31:15 2004
-+++ JIT/Base.pm Wed Jun 9 15:34:32 2004
-@@ -75,7 +75,7 @@
-
- foreach my $row (@$array) {
- croak("Bad param settings - found non hash-ref for loop row in loop $loop_name!")
-- unless ref $row eq 'HASH';
-+ unless ref $row && UNIVERSAL::isa($row, 'HASH');
-
- my $lc_name;
- foreach my $name (keys %$row) {
diff --git a/www/p5-HTML-Template-JIT/files/patch-t::03loops.t b/www/p5-HTML-Template-JIT/files/patch-t::03loops.t
deleted file mode 100644
index 83ebcd4f2ea1..000000000000
--- a/www/p5-HTML-Template-JIT/files/patch-t::03loops.t
+++ /dev/null
@@ -1,22 +0,0 @@
---- t/03loops.t Wed Jun 9 15:57:13 2004
-+++ t/03loops.t Wed Jun 9 16:00:15 2004
-@@ -1,4 +1,4 @@
--use Test::More tests => 8;
-+use Test::More tests => 9;
- use HTML::Template::JIT;
-
- my $debug = 0;
-@@ -69,3 +69,13 @@
- like($output, qr/Apples, Oranges, Brains, Toes, and Kiwi./);
- like($output, qr/pingpongpingpongpingpong/);
-
-+$template = HTML::Template::JIT->new(filename => 'loop.tmpl',
-+ path => ['t/templates'],
-+ jit_path => 't/jit_path',
-+ jit_debug => $debug,
-+ );
-+$template->param(foo => "FOO");
-+$template->param(bar => [ bless({ val => 'foo' }, 'barfoo'),
-+ bless({ val => 'bar' }, 'barbar') ]);
-+$output = $template->output();
-+like($output, qr/bar: foo,bar,/);
diff --git a/www/p5-HTML-Template-JIT/files/patch-t::10escape.t b/www/p5-HTML-Template-JIT/files/patch-t::10escape.t
deleted file mode 100644
index a2f5f54eab5f..000000000000
--- a/www/p5-HTML-Template-JIT/files/patch-t::10escape.t
+++ /dev/null
@@ -1,22 +0,0 @@
---- t/10escape.t Tue May 18 18:39:12 2004
-+++ t/10escape.t Tue May 18 18:42:03 2004
-@@ -1,4 +1,4 @@
--use Test::More tests => 3;
-+use Test::More tests => 4;
- use HTML::Template::JIT;
- my $debug = 0;
-
-@@ -35,3 +35,13 @@
- $output = $template->output;
- like($output, qr/Some URL escaped stuff:/);
-
-+# test 8bit char in urlescaped var
-+$template = HTML::Template::JIT->new(
-+ filename => 'urlescape.tmpl',
-+ path => ['t/templates'],
-+ jit_path => 't/jit_path',
-+ jit_debug => $debug,
-+ );
-+$template->param(STUFF => "\xf4"); #"
-+$output = $template->output;
-+like($output, qr/%F4/); #"