aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Template-JIT
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2007-08-31 13:37:23 +0000
committerMathieu Arnold <mat@FreeBSD.org>2007-08-31 13:37:23 +0000
commitd1850a3d8ce1023f97814bd5db8642bfc8e695e0 (patch)
treebba44484f7b230fd6b557cc34a841c889282242a /www/p5-HTML-Template-JIT
parentff334859ab3a3bf4271f7fce3a419dc3c28772be (diff)
downloadports-d1850a3d8ce1023f97814bd5db8642bfc8e695e0.tar.gz
ports-d1850a3d8ce1023f97814bd5db8642bfc8e695e0.zip
Use the CPAN site macro.
Use DISTVERSION in place of DISTNAME where possible. Remove perl 5.005 shims.
Notes
Notes: svn path=/head/; revision=198588
Diffstat (limited to 'www/p5-HTML-Template-JIT')
-rw-r--r--www/p5-HTML-Template-JIT/Makefile13
-rw-r--r--www/p5-HTML-Template-JIT/files/5.005-JIT-Compiler.pm21
2 files changed, 1 insertions, 33 deletions
diff --git a/www/p5-HTML-Template-JIT/Makefile b/www/p5-HTML-Template-JIT/Makefile
index dbb3079f7637..224e3c9e755b 100644
--- a/www/p5-HTML-Template-JIT/Makefile
+++ b/www/p5-HTML-Template-JIT/Makefile
@@ -8,8 +8,7 @@
PORTNAME= HTML-Template-JIT
PORTVERSION= 0.05
CATEGORIES= www perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= HTML
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
@@ -28,19 +27,9 @@ MAN3= HTML::Template::JIT.3 HTML::Template::JIT::Compiler.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${PATCHDIR}/5.005-JIT-Compiler.pm
-.endif
-
post-patch:
@${PERL} -i -pe 's/indent -kr/indent/' \
${WRKSRC}/JIT/Compiler.pm
-.if ${PERL_LEVEL} < 500600
- @${PERL} -i -pe '$$_ = "" if /warnings|5\.006/g;' \
- -e 's/\bour ([^ ;]+)/use vars qw{$$1};$$1/g;' \
- ${WRKSRC}/Makefile.PL ${WRKSRC}/JIT.pm \
- ${WRKSRC}/JIT/Base.pm ${WRKSRC}/JIT/Compiler.pm
-.endif
@${FIND} ${WRKSRC} -name '*.orig' -delete
.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Template-JIT/files/5.005-JIT-Compiler.pm b/www/p5-HTML-Template-JIT/files/5.005-JIT-Compiler.pm
deleted file mode 100644
index 0b1f011e076e..000000000000
--- a/www/p5-HTML-Template-JIT/files/5.005-JIT-Compiler.pm
+++ /dev/null
@@ -1,21 +0,0 @@
---- JIT/Compiler.pm~ Fri May 7 12:58:37 2004
-+++ JIT/Compiler.pm Fri May 7 12:58:39 2004
-@@ -87,6 +87,18 @@
- use Inline C => Config => OPTIMIZE => "$optimize", DIRECTORY => "$self->{package_dir}" $inline_debug;
- use Inline C => <<'CODE_END';
-
-+#ifndef SvPV_nolen
-+# define SvPV_nolen(sv) ((SvFLAGS(sv) & (SVf_POK)) == SVf_POK ? SvPVX(sv) : sv_2pv_nolen(sv))
-+ static char *
-+ sv_2pv_nolen(register SV *sv)
-+ {
-+ STRLEN n_a;
-+ return sv_2pv(sv, &n_a);
-+ }
-+#endif
-+
-+#define get_hv(name,create) perl_get_hv(name,create)
-+
- END
-
- # print out code