aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-TokeParser-Simple
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-06 12:34:02 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-06 12:34:02 +0000
commit8c0bf1dda6845ac83e3f8e0703c60181934dbfcf (patch)
tree8b751e3ae8e8ca013355a1418bfce4ae7d481f6e /www/p5-HTML-TokeParser-Simple
parent00337b72173321bfdfb24f9add4cef39935cab33 (diff)
downloadports-8c0bf1dda6845ac83e3f8e0703c60181934dbfcf.tar.gz
ports-8c0bf1dda6845ac83e3f8e0703c60181934dbfcf.zip
Add p5-HTML-TokeParser-Simple 2.2, subclass of HTML::TokeParser with
easy-to-remember method calls. PR: ports/65709 Submitted by: Lars Eggert <lars.eggert@gmx.net>
Notes
Notes: svn path=/head/; revision=108546
Diffstat (limited to 'www/p5-HTML-TokeParser-Simple')
-rw-r--r--www/p5-HTML-TokeParser-Simple/Makefile25
-rw-r--r--www/p5-HTML-TokeParser-Simple/distinfo2
-rw-r--r--www/p5-HTML-TokeParser-Simple/pkg-descr10
-rw-r--r--www/p5-HTML-TokeParser-Simple/pkg-plist7
4 files changed, 44 insertions, 0 deletions
diff --git a/www/p5-HTML-TokeParser-Simple/Makefile b/www/p5-HTML-TokeParser-Simple/Makefile
new file mode 100644
index 000000000000..fad830640969
--- /dev/null
+++ b/www/p5-HTML-TokeParser-Simple/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: HTML-TokeParser-Simple
+# Date created: 18 April 2004
+# Whom: Lars Eggert <lars.eggert@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-TokeParser-Simple
+PORTVERSION= 2.2
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Subclass of HTML::TokeParser with easy-to-remember method calls
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::TokeParser::Simple.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-TokeParser-Simple/distinfo b/www/p5-HTML-TokeParser-Simple/distinfo
new file mode 100644
index 000000000000..61392022f023
--- /dev/null
+++ b/www/p5-HTML-TokeParser-Simple/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTML-TokeParser-Simple-2.2.tar.gz) = 65b1974178b129c8b0efd1d2dcd91efb
+SIZE (HTML-TokeParser-Simple-2.2.tar.gz) = 9990
diff --git a/www/p5-HTML-TokeParser-Simple/pkg-descr b/www/p5-HTML-TokeParser-Simple/pkg-descr
new file mode 100644
index 000000000000..4487d4f17dab
--- /dev/null
+++ b/www/p5-HTML-TokeParser-Simple/pkg-descr
@@ -0,0 +1,10 @@
+HTML::TokeParser::Simple is a subclass of HTML::TokeParser that uses
+easy-to-remember method calls to work with the tokens. Rather than
+try to remember a bunch of array indices or try to write a bunch of
+constants for them, you can now do something like:
+
+ $token->is_start_tag( 'form' )
+
+Instead of
+
+ $token->[0] eq 'S' and $token->[1] eq 'form'
diff --git a/www/p5-HTML-TokeParser-Simple/pkg-plist b/www/p5-HTML-TokeParser-Simple/pkg-plist
new file mode 100644
index 000000000000..3558fb904541
--- /dev/null
+++ b/www/p5-HTML-TokeParser-Simple/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTML/TokeParser/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/TokeParser/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/TokeParser/Simple
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/TokeParser 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML/TokeParser 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true