aboutsummaryrefslogtreecommitdiff
path: root/www/p5-MasonX-WebApp/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-05-22 22:23:16 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-05-22 22:23:16 +0000
commit346fdfaa76c10977dac257f5f76c954fe8f0d665 (patch)
tree1812485a9aa222ba62eb3c4819b7bb7721e403f3 /www/p5-MasonX-WebApp/Makefile
parent622fd470b55acab4b8978d2bd611df89c1e02483 (diff)
downloadports-346fdfaa76c10977dac257f5f76c954fe8f0d665.tar.gz
ports-346fdfaa76c10977dac257f5f76c954fe8f0d665.zip
mod_perl2 was updated, this changes are needet to prevent
dependency loops - fix mod_perl/mod_perl2 dependency - p5-Apache-Reload is now included in mod_perl2 - make usage of CPAN author macro - bump portrevision commit with hat apache@
Notes
Notes: svn path=/head/; revision=274481
Diffstat (limited to 'www/p5-MasonX-WebApp/Makefile')
-rw-r--r--www/p5-MasonX-WebApp/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/www/p5-MasonX-WebApp/Makefile b/www/p5-MasonX-WebApp/Makefile
index cd4ee620af9c..86c77526c9d8 100644
--- a/www/p5-MasonX-WebApp/Makefile
+++ b/www/p5-MasonX-WebApp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= MasonX-WebApp
PORTVERSION= 0.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,9 +20,13 @@ RUN_DEPENDS= ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util
-BUILD_DEPENDS= ${RUN_DEPENDS}
-.if defined(WITH_MODPERL2)
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USE_APACHE_RUN= 13+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MODPERL2) || ${APACHE_VERSION} > 13
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.else
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
@@ -34,4 +38,4 @@ PERL_MODBUILD= yes
MAN3= MasonX::WebApp.3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>