aboutsummaryrefslogtreecommitdiff
path: root/www/p5-POE-Component-Server-HTTP/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-10 14:55:44 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-10 14:55:44 +0000
commit4a19b409fe0abae33f484498a4fb7dffe58ac457 (patch)
treecb5c56abcf4fe0a24ef8962b057477390342d54d /www/p5-POE-Component-Server-HTTP/Makefile
parentcd3006e8a84099700301f63269b7b58bd0b66b2e (diff)
downloadports-4a19b409fe0abae33f484498a4fb7dffe58ac457.tar.gz
ports-4a19b409fe0abae33f484498a4fb7dffe58ac457.zip
Add p5-POE-Component-Server-HTTP 0.04, POE Component to create HTTP Servers.
PR: ports/65139 Submitted by: Zach Thompson <lin-chi@lastamericanempire.com>
Notes
Notes: svn path=/head/; revision=108841
Diffstat (limited to 'www/p5-POE-Component-Server-HTTP/Makefile')
-rw-r--r--www/p5-POE-Component-Server-HTTP/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-POE-Component-Server-HTTP/Makefile b/www/p5-POE-Component-Server-HTTP/Makefile
new file mode 100644
index 000000000000..14a815f332b6
--- /dev/null
+++ b/www/p5-POE-Component-Server-HTTP/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: POE-Component-Server-HTTP
+# Date created: 03 Apr 2004
+# Whom: Zach Thompson <lin-chi@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Server-HTTP
+PORTVERSION= 0.04
+CATEGORIES= www devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lin-chi@lastamericanempire.com
+COMMENT= POE Component to create HTTP Servers
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTTP/Status.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Server::HTTP.3
+
+.include <bsd.port.mk>