aboutsummaryrefslogtreecommitdiff
path: root/www/p5-RT-Authen-ExternalAuth
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-09-30 21:53:55 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-09-30 21:53:55 +0000
commit874c797466ec2dc920e4d3c5cd02dc179d0e4f58 (patch)
tree6929ffac7bdb6af173bc01e7bed6bbd76ee1dcdd /www/p5-RT-Authen-ExternalAuth
parent264c555c5ed358d6f559775bebc841ba537913f7 (diff)
downloadports-874c797466ec2dc920e4d3c5cd02dc179d0e4f58.tar.gz
ports-874c797466ec2dc920e4d3c5cd02dc179d0e4f58.zip
- stagify the last 4 remaining of my ports
- Add patch for a bug in Module::Import::RTx which doesn't take any account of ${DESTDIR}. This is a known bug upstream which hasn't been fixed in 7 years or so since it was first reported... https://rt.cpan.org/Public/Bug/Display.html?id=12964
Notes
Notes: svn path=/head/; revision=328879
Diffstat (limited to 'www/p5-RT-Authen-ExternalAuth')
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile10
-rw-r--r--www/p5-RT-Authen-ExternalAuth/files/patch-inc_Module_Install_RTx.pm14
-rw-r--r--www/p5-RT-Authen-ExternalAuth/pkg-plist6
3 files changed, 23 insertions, 7 deletions
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
index a67411f68e1d..7f7ac54eaeb3 100644
--- a/www/p5-RT-Authen-ExternalAuth/Makefile
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -23,7 +23,6 @@ USE_PERL5= configure
OPTIONS_DEFINE= RT38
RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MRT38}
@@ -36,20 +35,19 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}
RUN_DEPENDS+= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}
MAN3PREFIX= ${PREFIX}
-MAN3= RT::Authen::ExternalAuth.3 \
- RT::Authen::ExternalAuth::DBI.3 \
- RT::Authen::ExternalAuth::DBI::Cookie.3 \
- RT::Authen::ExternalAuth::LDAP.3
PLIST_SUB+= RTHOME=share/rt${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
+
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
- ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//;' \
+ -e 's,^DESTDIR = ,DESTDIR = ${STAGEDIR},;' Makefile
+
.include <bsd.port.mk>
diff --git a/www/p5-RT-Authen-ExternalAuth/files/patch-inc_Module_Install_RTx.pm b/www/p5-RT-Authen-ExternalAuth/files/patch-inc_Module_Install_RTx.pm
new file mode 100644
index 000000000000..2703d0c788a0
--- /dev/null
+++ b/www/p5-RT-Authen-ExternalAuth/files/patch-inc_Module_Install_RTx.pm
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- inc/Module/Install/RTx.pm.orig
++++ inc/Module/Install/RTx.pm
+@@ -101,7 +101,7 @@
+ my %index = map { $_ => 1 } @INDEX_DIRS;
+ $self->no_index( directory => $_ ) foreach grep !$index{$_}, @DIRS;
+
+- my $args = join ', ', map "q($_)", map { ($_, $path{$_}) }
++ my $args = join ', ', map "q($_)", map { ($_, "\${DESTDIR}$path{$_}") }
+ grep $subdirs{$_}, keys %path;
+
+ print "./$_\t=> $path{$_}\n" for sort keys %subdirs;
diff --git a/www/p5-RT-Authen-ExternalAuth/pkg-plist b/www/p5-RT-Authen-ExternalAuth/pkg-plist
index 35a37b9dfaae..51e934f3e96f 100644
--- a/www/p5-RT-Authen-ExternalAuth/pkg-plist
+++ b/www/p5-RT-Authen-ExternalAuth/pkg-plist
@@ -1,4 +1,3 @@
-man/auto/RT/Authen/ExternalAuth/.packlist
%%RTHOME%%/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.pm
%%RTHOME%%/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/Elements/Header/Head
%%RTHOME%%/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Auth
@@ -8,6 +7,11 @@ man/auto/RT/Authen/ExternalAuth/.packlist
%%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/DBI.pm
%%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/DBI/Cookie.pm
%%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm
+man/man3/RT::Authen::ExternalAuth.3.gz
+man/man3/RT::Authen::ExternalAuth::DBI.3.gz
+man/man3/RT::Authen::ExternalAuth::DBI::Cookie.3.gz
+man/man3/RT::Authen::ExternalAuth::LDAP.3.gz
+man/auto/RT/Authen/ExternalAuth/.packlist.gz
@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/DBI
@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth
@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen