aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Router-Simple
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-02 06:31:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-02 06:31:04 +0000
commitf1265ea9c7fa3c8683fae4e7724f5f7f1530234d (patch)
tree7f5502f82eeb86f7cf5e3fd497e404e752bbd838 /www/p5-Router-Simple
parent062be893b8b651242ede3ff94d257ec537eb0620 (diff)
downloadports-f1265ea9c7fa3c8683fae4e7724f5f7f1530234d.tar.gz
ports-f1265ea9c7fa3c8683fae4e7724f5f7f1530234d.zip
- Add p5-Router-Simple 0.09
Router::Simple is a simple router class. Its main purpose is to serve as a dispatcher for web applications. Router::Simple can match against PSGI $env directly, which means it's easy to use with PSGI supporting web frameworks. WWW: http://search.cpan.org/dist/Router-Simple/ Feature safe: yes
Notes
Notes: svn path=/head/; revision=286755
Diffstat (limited to 'www/p5-Router-Simple')
-rw-r--r--www/p5-Router-Simple/Makefile37
-rw-r--r--www/p5-Router-Simple/distinfo2
-rw-r--r--www/p5-Router-Simple/pkg-descr5
-rw-r--r--www/p5-Router-Simple/pkg-plist10
4 files changed, 54 insertions, 0 deletions
diff --git a/www/p5-Router-Simple/Makefile b/www/p5-Router-Simple/Makefile
new file mode 100644
index 000000000000..63834794c97f
--- /dev/null
+++ b/www/p5-Router-Simple/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Router-Simple
+# Date created: 2011-11-30
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Router-Simple
+PORTVERSION= 0.09
+CATEGORIES= www net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TOKUHIROM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple HTTP Router
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+
+PERL_CONFIGURE= yes
+
+MAN3= Router::Simple.3 \
+ Router::Simple::Cookbook.3 \
+ Router::Simple::Declare.3 \
+ Router::Simple::Route.3 \
+ Router::Simple::SubMapper.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Router-Simple/distinfo b/www/p5-Router-Simple/distinfo
new file mode 100644
index 000000000000..b6ee00d7ed6d
--- /dev/null
+++ b/www/p5-Router-Simple/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Router-Simple-0.09.tar.gz) = c8d4cabd6c038a21c49bdf6c9a0dc96cdc65bfc443cca30c189721ca21310d91
+SIZE (Router-Simple-0.09.tar.gz) = 27923
diff --git a/www/p5-Router-Simple/pkg-descr b/www/p5-Router-Simple/pkg-descr
new file mode 100644
index 000000000000..2c30ed306998
--- /dev/null
+++ b/www/p5-Router-Simple/pkg-descr
@@ -0,0 +1,5 @@
+Router::Simple is a simple router class. Its main purpose is to serve as a
+dispatcher for web applications. Router::Simple can match against PSGI $env
+directly, which means it's easy to use with PSGI supporting web frameworks.
+
+WWW: http://search.cpan.org/dist/Router-Simple/
diff --git a/www/p5-Router-Simple/pkg-plist b/www/p5-Router-Simple/pkg-plist
new file mode 100644
index 000000000000..21daab94c764
--- /dev/null
+++ b/www/p5-Router-Simple/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Router/Simple.pm
+%%SITE_PERL%%/Router/Simple/Cookbook.pod
+%%SITE_PERL%%/Router/Simple/Declare.pm
+%%SITE_PERL%%/Router/Simple/Route.pm
+%%SITE_PERL%%/Router/Simple/SubMapper.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Router/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Router/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Router
+@dirrm %%SITE_PERL%%/Router/Simple
+@dirrmtry %%SITE_PERL%%/Router