aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Template-GD
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-23 08:52:44 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-23 08:52:44 +0000
commitd74664f0e1313f5722133e6494483fa315d7c8be (patch)
tree6334d67cc6921268ceb452f56eb230d52ab1cb73 /www/p5-Template-GD
parentd9faeef8e694f493eb37fa42c04aedc7ad51b6ca (diff)
downloadports-d74664f0e1313f5722133e6494483fa315d7c8be.tar.gz
ports-d74664f0e1313f5722133e6494483fa315d7c8be.zip
The Template-GD distribution provides a number of Template Toolkit
plugin modules to interface with Lincoln Stein's GD modules. These in turn provide an interface to Thomas Boutell's GD graphics library. WWW: http://search.cpan.org/dist/Template-GD/ PR: ports/99335 Submitted by: Greg Larkin <glarkin@sourcehosting.net>
Notes
Notes: svn path=/head/; revision=166093
Diffstat (limited to 'www/p5-Template-GD')
-rw-r--r--www/p5-Template-GD/Makefile47
-rw-r--r--www/p5-Template-GD/distinfo3
-rw-r--r--www/p5-Template-GD/pkg-descr5
-rw-r--r--www/p5-Template-GD/pkg-plist25
4 files changed, 80 insertions, 0 deletions
diff --git a/www/p5-Template-GD/Makefile b/www/p5-Template-GD/Makefile
new file mode 100644
index 000000000000..b469b9041ff6
--- /dev/null
+++ b/www/p5-Template-GD/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-Template-GD
+# Date created: 22 June 2006
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-GD
+PORTVERSION= 2.66
+CATEGORIES= www textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= Template Toolkit plugin to interface with GD modules
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Plugin::GD.3 \
+ Template::Plugin::GD::Constants.3 \
+ Template::Plugin::GD::Graph::area.3 \
+ Template::Plugin::GD::Graph::bars.3 \
+ Template::Plugin::GD::Graph::bars3d.3 \
+ Template::Plugin::GD::Graph::lines.3 \
+ Template::Plugin::GD::Graph::lines3d.3 \
+ Template::Plugin::GD::Graph::linespoints.3 \
+ Template::Plugin::GD::Graph::mixed.3 \
+ Template::Plugin::GD::Graph::pie.3 \
+ Template::Plugin::GD::Graph::pie3d.3 \
+ Template::Plugin::GD::Graph::points.3 \
+ Template::Plugin::GD::Image.3 \
+ Template::Plugin::GD::Polygon.3 \
+ Template::Plugin::GD::Text.3 \
+ Template::Plugin::GD::Text::Align.3 \
+ Template::Plugin::GD::Text::Wrap.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Template-GD/distinfo b/www/p5-Template-GD/distinfo
new file mode 100644
index 000000000000..24df29205784
--- /dev/null
+++ b/www/p5-Template-GD/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-GD-2.66.tar.gz) = 9052bef9bd799e143990e67422c14b81
+SHA256 (Template-GD-2.66.tar.gz) = 98523c8192f2e8184042e5a2e172bd767ac289dd2e480f35f680dce32160905b
+SIZE (Template-GD-2.66.tar.gz) = 12827
diff --git a/www/p5-Template-GD/pkg-descr b/www/p5-Template-GD/pkg-descr
new file mode 100644
index 000000000000..7261edc3798e
--- /dev/null
+++ b/www/p5-Template-GD/pkg-descr
@@ -0,0 +1,5 @@
+The Template-GD distribution provides a number of Template Toolkit
+plugin modules to interface with Lincoln Stein's GD modules. These in
+turn provide an interface to Thomas Boutell's GD graphics library.
+
+WWW: http://search.cpan.org/dist/Template-GD/
diff --git a/www/p5-Template-GD/pkg-plist b/www/p5-Template-GD/pkg-plist
new file mode 100644
index 000000000000..1cf68bbc4763
--- /dev/null
+++ b/www/p5-Template-GD/pkg-plist
@@ -0,0 +1,25 @@
+%%SITE_PERL%%/Template/Plugin/GD.pm
+%%SITE_PERL%%/Template/Plugin/GD/Constants.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/area.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/bars.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/bars3d.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/lines.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/lines3d.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/linespoints.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/mixed.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/pie.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/pie3d.pm
+%%SITE_PERL%%/Template/Plugin/GD/Graph/points.pm
+%%SITE_PERL%%/Template/Plugin/GD/Image.pm
+%%SITE_PERL%%/Template/Plugin/GD/Polygon.pm
+%%SITE_PERL%%/Template/Plugin/GD/Text.pm
+%%SITE_PERL%%/Template/Plugin/GD/Text/Align.pm
+%%SITE_PERL%%/Template/Plugin/GD/Text/Wrap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/GD/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/GD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrmtry %%SITE_PERL%%/Template/Plugin/GD/Text
+@dirrmtry %%SITE_PERL%%/Template/Plugin/GD/Graph
+@dirrmtry %%SITE_PERL%%/Template/Plugin/GD
+@dirrmtry %%SITE_PERL%%/Template/Plugin
+@dirrmtry %%SITE_PERL%%/Template