aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Template-Plugin-Class
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-06-24 20:31:43 +0000
committerLars Thegler <lth@FreeBSD.org>2004-06-24 20:31:43 +0000
commited65da09c540082b8954a1dd3ddceecd99ba6028 (patch)
tree6fa061441ec7360e628431be38061bad793f1da1 /www/p5-Template-Plugin-Class
parentb8df2f549a148af97670d998daec2d20ce2b8fd7 (diff)
downloadports-ed65da09c540082b8954a1dd3ddceecd99ba6028.tar.gz
ports-ed65da09c540082b8954a1dd3ddceecd99ba6028.zip
Add p5-Template-Plugin-Class 0.12,
allow calling of class methods on arbitrary classes.
Notes
Notes: svn path=/head/; revision=112169
Diffstat (limited to 'www/p5-Template-Plugin-Class')
-rw-r--r--www/p5-Template-Plugin-Class/Makefile25
-rw-r--r--www/p5-Template-Plugin-Class/distinfo2
-rw-r--r--www/p5-Template-Plugin-Class/pkg-descr4
-rw-r--r--www/p5-Template-Plugin-Class/pkg-plist3
4 files changed, 34 insertions, 0 deletions
diff --git a/www/p5-Template-Plugin-Class/Makefile b/www/p5-Template-Plugin-Class/Makefile
new file mode 100644
index 000000000000..63edda813a2b
--- /dev/null
+++ b/www/p5-Template-Plugin-Class/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Template-Plugin-Class
+# Date created: 24 June 2004
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Plugin-Class
+PORTVERSION= 0.12
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Allow calling of class methods on arbitrary classes
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Template::Plugin::Class.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Template-Plugin-Class/distinfo b/www/p5-Template-Plugin-Class/distinfo
new file mode 100644
index 000000000000..51d29b5aa824
--- /dev/null
+++ b/www/p5-Template-Plugin-Class/distinfo
@@ -0,0 +1,2 @@
+MD5 (Template-Plugin-Class-0.12.tar.gz) = 2ed01153031599494f616b4cbdf87ab1
+SIZE (Template-Plugin-Class-0.12.tar.gz) = 2794
diff --git a/www/p5-Template-Plugin-Class/pkg-descr b/www/p5-Template-Plugin-Class/pkg-descr
new file mode 100644
index 000000000000..34bf2e639ef0
--- /dev/null
+++ b/www/p5-Template-Plugin-Class/pkg-descr
@@ -0,0 +1,4 @@
+Template::Plugin::Class allows you to call class methods on arbitrary
+classes. One use for this is in Class::DBI style applications.
+
+WWW: http://search.cpan.org/dist/Template-Plugin-Class/
diff --git a/www/p5-Template-Plugin-Class/pkg-plist b/www/p5-Template-Plugin-Class/pkg-plist
new file mode 100644
index 000000000000..bc53ab2142f4
--- /dev/null
+++ b/www/p5-Template-Plugin-Class/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Template/Plugin/Class.pm
+@unexec rmdir %D/%%SITE_PERL%%/Template/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Template 2>/dev/null || true