aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Tenjin
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-12-04 06:37:18 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-12-04 06:37:18 +0000
commitd4c63d6872c497b73f88f3f98f1cd3a732e3341b (patch)
tree63bf796e61ee822739a85b8080ab8a9c7b5fa031 /www/p5-Tenjin
parent9eb41dc7653b0fdba507f5c34ec1a131760074ae (diff)
downloadports-d4c63d6872c497b73f88f3f98f1cd3a732e3341b.tar.gz
ports-d4c63d6872c497b73f88f3f98f1cd3a732e3341b.zip
Fast templating engine with support for embedded Perl.
Notes
Notes: svn path=/head/; revision=245187
Diffstat (limited to 'www/p5-Tenjin')
-rw-r--r--www/p5-Tenjin/Makefile27
-rw-r--r--www/p5-Tenjin/distinfo3
-rw-r--r--www/p5-Tenjin/pkg-descr3
-rw-r--r--www/p5-Tenjin/pkg-plist11
4 files changed, 44 insertions, 0 deletions
diff --git a/www/p5-Tenjin/Makefile b/www/p5-Tenjin/Makefile
new file mode 100644
index 000000000000..4e38f5866fbd
--- /dev/null
+++ b/www/p5-Tenjin/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Tenjin
+# Date created: 04 Dec 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tenjin
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for fast templating engine with support for embedded
+
+PERL_CONFIGURE= yes
+
+MAN3= Tenjin.3 \
+ Tenjin::Context.3 \
+ Tenjin::Engine.3 \
+ Tenjin::HTML.3 \
+ Tenjin::Preprocessor.3 \
+ Tenjin::Template.3 \
+ Tenjin::Util.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Tenjin/distinfo b/www/p5-Tenjin/distinfo
new file mode 100644
index 000000000000..7fdb14236a9f
--- /dev/null
+++ b/www/p5-Tenjin/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tenjin-0.04.tar.gz) = 702602a128cfca968170af8d9818161a
+SHA256 (Tenjin-0.04.tar.gz) = 4bbee54e39a85cfd42fb2f40052fe70c310109607874b55eb6e3b052a07f816a
+SIZE (Tenjin-0.04.tar.gz) = 31869
diff --git a/www/p5-Tenjin/pkg-descr b/www/p5-Tenjin/pkg-descr
new file mode 100644
index 000000000000..3387a8ddcd48
--- /dev/null
+++ b/www/p5-Tenjin/pkg-descr
@@ -0,0 +1,3 @@
+Fast templating engine with support for embedded Perl.
+
+WWW: http://search.cpan.org/dist/Tenjin/
diff --git a/www/p5-Tenjin/pkg-plist b/www/p5-Tenjin/pkg-plist
new file mode 100644
index 000000000000..d02b9326f356
--- /dev/null
+++ b/www/p5-Tenjin/pkg-plist
@@ -0,0 +1,11 @@
+bin/pltenjin
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tenjin/.packlist
+%%SITE_PERL%%/Tenjin.pm
+%%SITE_PERL%%/Tenjin/Context.pm
+%%SITE_PERL%%/Tenjin/Engine.pm
+%%SITE_PERL%%/Tenjin/HTML.pm
+%%SITE_PERL%%/Tenjin/Preprocessor.pm
+%%SITE_PERL%%/Tenjin/Template.pm
+%%SITE_PERL%%/Tenjin/Util.pm
+@dirrmtry %%SITE_PERL%%/Tenjin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tenjin