aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Test-HTTP
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-11 03:44:33 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-11 03:44:33 +0000
commit113e33a964c3e8ec8bd94eda635b30f5f61a3405 (patch)
tree341d1c9c70d95a1c6cc67d886540a435500eb6fb /www/p5-Test-HTTP
parentb89ef10dab6eaba8345bdfccbe2cd17944e98db7 (diff)
downloadports-113e33a964c3e8ec8bd94eda635b30f5f61a3405.tar.gz
ports-113e33a964c3e8ec8bd94eda635b30f5f61a3405.zip
- simplify dependencies
- encode_utf8($uri) only when needed - bump PORTREVISION PR: ports/141178 Submitted by: leeym Approved by: maintainer timeout (skv; > 1 month)
Notes
Notes: svn path=/head/; revision=247578
Diffstat (limited to 'www/p5-Test-HTTP')
-rw-r--r--www/p5-Test-HTTP/Makefile13
-rw-r--r--www/p5-Test-HTTP/patch-lib__Test__HTTP.pm11
2 files changed, 18 insertions, 6 deletions
diff --git a/www/p5-Test-HTTP/Makefile b/www/p5-Test-HTTP/Makefile
index eb735fbbce14..63038e36af27 100644
--- a/www/p5-Test-HTTP/Makefile
+++ b/www/p5-Test-HTTP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-HTTP
PORTVERSION= 0.14
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,15 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Test HTTP interactions
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
- ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple \
- ${SITE_PERL}/Class/Field.pm:${PORTSDIR}/devel/p5-Class-Field \
- ${SITE_PERL}/Test/Builder/Module.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Class-Field>=0:${PORTSDIR}/devel/p5-Class-Field \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= YES
MAN3= Test::HTTP.3 Test::HTTP::Syntax.3
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -delete
+
.include <bsd.port.mk>
diff --git a/www/p5-Test-HTTP/patch-lib__Test__HTTP.pm b/www/p5-Test-HTTP/patch-lib__Test__HTTP.pm
new file mode 100644
index 000000000000..d4ee8e5ac8b9
--- /dev/null
+++ b/www/p5-Test-HTTP/patch-lib__Test__HTTP.pm
@@ -0,0 +1,11 @@
+--- lib/Test/HTTP.pm.orig 2009-12-04 12:44:29.000000000 -0800
++++ lib/Test/HTTP.pm 2009-12-04 12:45:12.000000000 -0800
+@@ -234,7 +234,7 @@
+ sub new_request {
+ my ( $self, $method, $uri, @args ) = @_;
+ $self->request(
+- HTTP::Request->new( $method => encode_utf8($uri), @args ) );
++ HTTP::Request->new( $method => (is_utf8($uri) ? encode_utf8($uri) : $uri), @args ) );
+ $self->request->authorization_basic($self->username, $self->password)
+ if (defined $self->username) || (defined $self->password);
+ return $self->request;