aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Contact
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-02 05:35:48 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-02 05:35:48 +0000
commit4c697e03f2fdaf8643928121f0a46f6d828f6a35 (patch)
tree507bd9d5f8f33f80b1d244585c4bc74b9dc9231f /www/p5-WWW-Contact
parentbf1c027dd86b51a6ae4187afcf957a83bd8e16c3 (diff)
downloadports-4c697e03f2fdaf8643928121f0a46f6d828f6a35.tar.gz
ports-4c697e03f2fdaf8643928121f0a46f6d828f6a35.zip
Perl5 contact importer for use with all the major email systems, such as
Yahoo!, Gmail, Hotmail, etc. WWW: http://search.cpan.org/dist/WWW-Contact/ PR: ports/144404 Submitted by: Fred Cox <sailorfred@yahoo.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=250490
Diffstat (limited to 'www/p5-WWW-Contact')
-rw-r--r--www/p5-WWW-Contact/Makefile47
-rw-r--r--www/p5-WWW-Contact/distinfo3
-rw-r--r--www/p5-WWW-Contact/pkg-descr4
-rw-r--r--www/p5-WWW-Contact/pkg-plist21
4 files changed, 75 insertions, 0 deletions
diff --git a/www/p5-WWW-Contact/Makefile b/www/p5-WWW-Contact/Makefile
new file mode 100644
index 000000000000..018fdc1d73d6
--- /dev/null
+++ b/www/p5-WWW-Contact/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-WWW-Contact
+# Date created: 2010/02/22
+# Whom: Fred Cox
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Contact
+PORTVERSION= 0.37
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/F/FA/FAYLAND/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sailorfred@yahoo.com
+COMMENT= Contact importer for all the major email systems
+
+RUN_DEPENDS= ${SITE_PERL}/HTML/TokeParser/Simple.pm:${PORTSDIR}/www/p5-HTML-TokeParser-Simple \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/${PERL_ARCH}/JSON/XS.pm:${PORTSDIR}/converters/p5-JSON-XS \
+ ${SITE_PERL}/Text/vCard/Addressbook.pm:${PORTSDIR}/textproc/p5-Text-vCard \
+ ${SITE_PERL}/WWW/Mechanize/GZip.pm:${PORTSDIR}/www/p5-WWW-Mechanize-GZip \
+ ${SITE_PERL}/Net/Google/AuthSub.pm:${PORTSDIR}/net/p5-Net-Google-AuthSub \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${SITE_PERL}/${PERL_ARCH}/Moose.pm:${PORTSDIR}/devel/p5-Moose
+
+PERL_CONFIGURE= yes
+USE_PERL5= yes
+
+MAN3= WWW::Contact.3 \
+ WWW::Contact::Base.3 \
+ WWW::Contact::Plaxo.3\
+ WWW::Contact::Rediffmail.3 \
+ WWW::Contact::CN::163.3 \
+ WWW::Contact::GoogleContactsAPI.3 \
+ WWW::Contact::Lycos.3 \
+ WWW::Contact::Yahoo.3 \
+ WWW::Contact::Indiatimes.3 \
+ WWW::Contact::BG::Abv.3 \
+ WWW::Contact::BG::Mail.3 \
+ WWW::Contact::Mail.3 \
+ WWW::Contact::Hotmail.3 \
+ WWW::Contact::AOL.3 \
+ WWW::Contact::Gmail.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Contact/distinfo b/www/p5-WWW-Contact/distinfo
new file mode 100644
index 000000000000..24b2b4751296
--- /dev/null
+++ b/www/p5-WWW-Contact/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Contact-0.37.tar.gz) = 77cff7f4a29bf4e64a38b7aa1ef9064c
+SHA256 (WWW-Contact-0.37.tar.gz) = f9cc44a311864258f68329d0574bd6ff0b30167ed287e834cbda84c48194dbc5
+SIZE (WWW-Contact-0.37.tar.gz) = 18479
diff --git a/www/p5-WWW-Contact/pkg-descr b/www/p5-WWW-Contact/pkg-descr
new file mode 100644
index 000000000000..3481521ae816
--- /dev/null
+++ b/www/p5-WWW-Contact/pkg-descr
@@ -0,0 +1,4 @@
+Perl5 contact importer for use with all the major email systems, such as
+Yahoo!, Gmail, Hotmail, etc.
+
+WWW: http://search.cpan.org/dist/WWW-Contact/
diff --git a/www/p5-WWW-Contact/pkg-plist b/www/p5-WWW-Contact/pkg-plist
new file mode 100644
index 000000000000..fd768d5af1bf
--- /dev/null
+++ b/www/p5-WWW-Contact/pkg-plist
@@ -0,0 +1,21 @@
+%%SITE_PERL%%/WWW/Contact.pm
+%%SITE_PERL%%/WWW/Contact/Base.pm
+%%SITE_PERL%%/WWW/Contact/Plaxo.pm
+%%SITE_PERL%%/WWW/Contact/Rediffmail.pm
+%%SITE_PERL%%/WWW/Contact/GoogleContactsAPI.pm
+%%SITE_PERL%%/WWW/Contact/Lycos.pm
+%%SITE_PERL%%/WWW/Contact/Yahoo.pm
+%%SITE_PERL%%/WWW/Contact/Indiatimes.pm
+%%SITE_PERL%%/WWW/Contact/Mail.pm
+%%SITE_PERL%%/WWW/Contact/Hotmail.pm
+%%SITE_PERL%%/WWW/Contact/AOL.pm
+%%SITE_PERL%%/WWW/Contact/Gmail.pm
+%%SITE_PERL%%/WWW/Contact/CN/163.pm
+%%SITE_PERL%%/WWW/Contact/BG/Abv.pm
+%%SITE_PERL%%/WWW/Contact/BG/Mail.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Contact/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Contact
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrm %%SITE_PERL%%/WWW/Contact/BG
+@dirrm %%SITE_PERL%%/WWW/Contact/CN
+@dirrm %%SITE_PERL%%/WWW/Contact