aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mechanize
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-03 10:29:21 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-03 10:29:21 +0000
commit61e9d16e6ec33ed34287cd6b882420117aeff72c (patch)
treedcf4e5bed5441193de48499d73bf9a97bad0d6e3 /www/p5-WWW-Mechanize
parent5114a87c98093ae9965af7c0249b8f371630271d (diff)
downloadports-61e9d16e6ec33ed34287cd6b882420117aeff72c.tar.gz
ports-61e9d16e6ec33ed34287cd6b882420117aeff72c.zip
Update to 0.60
maintainer timeout PR: 55314 Submitted by: myself
Notes
Notes: svn path=/head/; revision=90086
Diffstat (limited to 'www/p5-WWW-Mechanize')
-rw-r--r--www/p5-WWW-Mechanize/Makefile14
-rw-r--r--www/p5-WWW-Mechanize/distinfo2
-rw-r--r--www/p5-WWW-Mechanize/files/patch-Makefile.PL42
-rw-r--r--www/p5-WWW-Mechanize/pkg-plist11
4 files changed, 43 insertions, 26 deletions
diff --git a/www/p5-WWW-Mechanize/Makefile b/www/p5-WWW-Mechanize/Makefile
index 99a26e9949a4..3009c48eb78a 100644
--- a/www/p5-WWW-Mechanize/Makefile
+++ b/www/p5-WWW-Mechanize/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= WWW-Mechanize
-PORTVERSION= 0.51
+PORTVERSION= 0.60
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= WWW
@@ -16,26 +16,26 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= This module is to help you automate interaction with a website
BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+ ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= WWW::Mechanize.3
+MAN3= WWW::Mechanize.3 WWW::Mechanize::Examples.3 WWW::Mechanize::Link.3
+MAN1= mech-dump.1
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
post-patch:
${PERL} -pi \
-e 's/^our\s+([\$$\@]\w+)/use vars qw($$1);$$1/;' \
-e 's/^our\s+([\%]\w+)/use vars qw($$1)/;' \
- -e '$$_="" if /require 5/;' \
-e '$$_="" if /use warnings/;' \
- ${WRKSRC}/lib/WWW/Mechanize.pm
+ ${WRKSRC}/lib/WWW/Mechanize.pm ${WRKSRC}/lib/WWW/Mechanize/Link.pm
+.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Mechanize/distinfo b/www/p5-WWW-Mechanize/distinfo
index 7bf9d0cc0e68..941cad3bc032 100644
--- a/www/p5-WWW-Mechanize/distinfo
+++ b/www/p5-WWW-Mechanize/distinfo
@@ -1 +1 @@
-MD5 (WWW-Mechanize-0.51.tar.gz) = 381ea59646ddae319f224e6b124f4324
+MD5 (WWW-Mechanize-0.60.tar.gz) = 26736aa802cede1c005a284a0bcef8ae
diff --git a/www/p5-WWW-Mechanize/files/patch-Makefile.PL b/www/p5-WWW-Mechanize/files/patch-Makefile.PL
index d593a30a2779..74315e8146d0 100644
--- a/www/p5-WWW-Mechanize/files/patch-Makefile.PL
+++ b/www/p5-WWW-Mechanize/files/patch-Makefile.PL
@@ -1,7 +1,7 @@
---- Makefile.PL.orig Fri Jul 4 14:04:35 2003
-+++ Makefile.PL Fri Jul 4 14:07:13 2003
-@@ -2,27 +2,7 @@ use ExtUtils::MakeMaker qw( WriteMakefil
- use strict;
+--- Makefile.PL.orig Mon Aug 18 03:35:42 2003
++++ Makefile.PL Fri Oct 3 11:47:30 2003
+@@ -5,28 +5,7 @@
+ use constant FLAG_SKIPMECHDUMP => "t/SKIP-MECH-FORMS";
# Much logic stolen fromm libwww-perl's Makefile.PL
-my $skiplive = 0;
@@ -16,8 +16,9 @@
-} else {
- print <<EOT;
-
--It seems that you are not directly connected to the Internet. Many of
--the WWW::Mechanize tests interact with websites such as Google.
+-It seems that you are not directly connected to the Internet. Some
+-of the WWW::Mechanize tests interact with websites such as Google,
+-in addition to its own internal tests.
-
-EOT
-
@@ -27,14 +28,29 @@
-} # failed connect
+my $skiplive = 1;
- my $filename = "t/SKIPLIVE";
- if ( $skiplive ) {
-@@ -55,8 +35,6 @@ my $parms = {
- },
+ my $tests = 't/*.t';
+ $tests .= ' t/live/*.t' unless $skiplive;
+@@ -53,17 +32,17 @@
+ 'test' => { TESTS => $tests },
};
--if ( prompt( "Do you want to install the mech-forms utility?", "y" ) =~ /^y/i ) {
- $parms->{EXE_FILES} = [ 'script/mech-forms' ];
+-if ( prompt( "Do you want to install the mech-dump utility?", "y" ) =~ /^y/i ) {
++#if ( prompt( "Do you want to install the mech-dump utility?", "y" ) =~ /^y/i ) {
+ $parms->{EXE_FILES} = [ 'script/mech-dump' ];
+ $parms->{PREREQ_PM}->{'Getopt::Long'} = 0;
+ $parms->{PREREQ_PM}->{'Pod::Usage'} = 0;
+
+- local @ARGV = FLAG_SKIPMECHDUMP;
++ local @ARGV = (@ARGV, FLAG_SKIPMECHDUMP);
+ rm_f();
+-} else {
+- local @ARGV = FLAG_SKIPMECHDUMP;
+- touch();
-}
++#} else {
++# local @ARGV = FLAG_SKIPMECHDUMP;
++# touch();
++#}
+
- WriteMakefile( %$parms );
+ eval { require IO::Socket::SSL };
diff --git a/www/p5-WWW-Mechanize/pkg-plist b/www/p5-WWW-Mechanize/pkg-plist
index 0ab4965b1c7c..d1af432e3ea1 100644
--- a/www/p5-WWW-Mechanize/pkg-plist
+++ b/www/p5-WWW-Mechanize/pkg-plist
@@ -1,8 +1,9 @@
-bin/mech-forms
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/.packlist
-%%SITE_PERL%%/WWW/Mechanize/Examples.pod
+bin/mech-dump
%%SITE_PERL%%/WWW/Mechanize.pm
-@dirrm %%SITE_PERL%%/WWW/Mechanize
-@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize 2>/dev/null || true
+%%SITE_PERL%%/WWW/Mechanize/Examples.pod
+%%SITE_PERL%%/WWW/Mechanize/Link.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW 2>/dev/null || true
+@dirrm %%SITE_PERL%%/WWW/Mechanize
@unexec rmdir %D/%%SITE_PERL%%/WWW 2>/dev/null || true