aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Plurk
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-10 05:44:35 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-10 05:44:35 +0000
commit460b357ccffa79241ea1fd03c97305fd56ba4b3f (patch)
treeab57a2ae47f64681f807fcf67e83e90fd3d7d699 /www/p5-WWW-Plurk
parentcfa5c41e4184cf696e849256b1157dbc9360bc68 (diff)
downloadports-460b357ccffa79241ea1fd03c97305fd56ba4b3f.tar.gz
ports-460b357ccffa79241ea1fd03c97305fd56ba4b3f.zip
This is an unofficial API for plurk.com. It uses the same interfaces that
plurk itself uses internally which are not published and not necessarily stable. When Plurk publish a stable API this module will be updated to take advantage of it. In the mean time use with caution. Ryan Lim did the heavy lifting of reverse engineering the API. His PHP implementation can be found at http://code.google.com/p/rlplurkapi/. If you'd like to lend a hand supporting the bits of Plurk that this API doesn't yet reach please feel free to send me a patch. The Plurk API Wiki at http://plurkwiki.badchemicals.net/ is a good source of information. Author: Andy Armstrong <andy.armstrong@messagesystems.com> WWW: http://search.cpan.org/dist/WWW-Plurk/ PR: ports/126404 Submitted by: Yi-Hsuan Hsin <mhsin at mhsin.org>
Notes
Notes: svn path=/head/; revision=218309
Diffstat (limited to 'www/p5-WWW-Plurk')
-rw-r--r--www/p5-WWW-Plurk/Makefile30
-rw-r--r--www/p5-WWW-Plurk/distinfo3
-rw-r--r--www/p5-WWW-Plurk/pkg-descr14
-rw-r--r--www/p5-WWW-Plurk/pkg-plist9
4 files changed, 56 insertions, 0 deletions
diff --git a/www/p5-WWW-Plurk/Makefile b/www/p5-WWW-Plurk/Makefile
new file mode 100644
index 000000000000..3f06e207bbaf
--- /dev/null
+++ b/www/p5-WWW-Plurk/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-WWW-Plurk
+# Date created: 2008-08-04
+# Whom: Yi-Hsuan Hsin <mhsin@mhsin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Plurk
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mhsin@mhsin.org
+COMMENT= Unofficial plurk.com API
+
+BUILD_DEPENDS= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece \
+ p5-DateTime-Format-Mail>=0:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
+ ${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
+ p5-JSON>=2.00:${PORTSDIR}/converters/p5-JSON \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-HTML-Tiny>=0:${PORTSDIR}/textproc/p5-HTML-Tiny \
+ p5-Math-Base36>=0:${PORTSDIR}/math/p5-Math-Base36
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Plurk.3 WWW::Plurk::Friend.3 WWW::Plurk::Message.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Plurk/distinfo b/www/p5-WWW-Plurk/distinfo
new file mode 100644
index 000000000000..8e302c1ddf3e
--- /dev/null
+++ b/www/p5-WWW-Plurk/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Plurk-0.02.tar.gz) = 37ecb2ea9e4492c13168299289b5888a
+SHA256 (WWW-Plurk-0.02.tar.gz) = 521f9b29ccf5af936cdb79d37d83717ab0dd03b849350bc2dc307184b4acc318
+SIZE (WWW-Plurk-0.02.tar.gz) = 12582
diff --git a/www/p5-WWW-Plurk/pkg-descr b/www/p5-WWW-Plurk/pkg-descr
new file mode 100644
index 000000000000..734f50ade293
--- /dev/null
+++ b/www/p5-WWW-Plurk/pkg-descr
@@ -0,0 +1,14 @@
+This is an unofficial API for plurk.com. It uses the same interfaces that
+plurk itself uses internally which are not published and not necessarily
+stable. When Plurk publish a stable API this module will be updated to take
+advantage of it. In the mean time use with caution.
+
+Ryan Lim did the heavy lifting of reverse engineering the API. His PHP
+implementation can be found at http://code.google.com/p/rlplurkapi/.
+
+If you'd like to lend a hand supporting the bits of Plurk that this API
+doesn't yet reach please feel free to send me a patch. The Plurk API Wiki at
+http://plurkwiki.badchemicals.net/ is a good source of information.
+
+Author: Andy Armstrong <andy.armstrong@messagesystems.com>
+WWW: http://search.cpan.org/dist/WWW-Plurk/
diff --git a/www/p5-WWW-Plurk/pkg-plist b/www/p5-WWW-Plurk/pkg-plist
new file mode 100644
index 000000000000..2ff44c80d9ab
--- /dev/null
+++ b/www/p5-WWW-Plurk/pkg-plist
@@ -0,0 +1,9 @@
+bin/plurk
+%%SITE_PERL%%/WWW/Plurk.pm
+%%SITE_PERL%%/WWW/Plurk/Friend.pm
+%%SITE_PERL%%/WWW/Plurk/Message.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Plurk/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Plurk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrm %%SITE_PERL%%/WWW/Plurk
+@dirrmtry %%SITE_PERL%%/WWW