aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-iTunesConnect
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-08 10:21:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-08 10:21:48 +0000
commit6fc5e844e6793de0844d803cd92261c329822622 (patch)
tree35655790e326e216849e09271560bd0551a31c7b /www/p5-WWW-iTunesConnect
parent7eabca377fefb051cf822f4d2f6ee7cf5470b4f8 (diff)
downloadports-6fc5e844e6793de0844d803cd92261c329822622.tar.gz
ports-6fc5e844e6793de0844d803cd92261c329822622.zip
A Perl5 client interface for Apple's iTunes Connect service.
WWW: http://search.cpan.org/~bfoz/p5-WWW-iTunesConnect/ PR: ports/145405 Submitted by: Brandon Fosdick <bfoz at bfoz.net>
Notes
Notes: svn path=/head/; revision=253944
Diffstat (limited to 'www/p5-WWW-iTunesConnect')
-rw-r--r--www/p5-WWW-iTunesConnect/Makefile33
-rw-r--r--www/p5-WWW-iTunesConnect/distinfo3
-rw-r--r--www/p5-WWW-iTunesConnect/pkg-descr3
3 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-WWW-iTunesConnect/Makefile b/www/p5-WWW-iTunesConnect/Makefile
new file mode 100644
index 000000000000..93a553d7429f
--- /dev/null
+++ b/www/p5-WWW-iTunesConnect/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-WWW-iTunesConnect
+# Date created: 29 August 2009
+# Whom: Brandon Fosdick <bfoz@bfoz.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-iTunesConnect
+PORTVERSION= 1.14
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PKGNAME}
+
+MAINTAINER= bfoz@bfoz.net
+COMMENT= Client interface for Apple's iTunes Connect service
+
+BUILD_DEPENDS= p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-IO-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Compress-Zlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= WWW::iTunesConnect.3
+
+PLIST_FILES= %%SITE_PERL%%/WWW/iTunesConnect.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/iTunesConnect/.packlist
+PLIST_DIRS= %%SITE_PERL%%/WWW \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/iTunesConnect \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-iTunesConnect/distinfo b/www/p5-WWW-iTunesConnect/distinfo
new file mode 100644
index 000000000000..ae9cdc69aa6d
--- /dev/null
+++ b/www/p5-WWW-iTunesConnect/distinfo
@@ -0,0 +1,3 @@
+MD5 (p5-WWW-iTunesConnect-1.14.tar.gz) = 2662526f37a2f8f0eb304c82e9a94221
+SHA256 (p5-WWW-iTunesConnect-1.14.tar.gz) = 4916c9b18d4d95f626f2124256dbd7c3ca28c162c042cfa5fb2fb9cab5fb8e5d
+SIZE (p5-WWW-iTunesConnect-1.14.tar.gz) = 7994
diff --git a/www/p5-WWW-iTunesConnect/pkg-descr b/www/p5-WWW-iTunesConnect/pkg-descr
new file mode 100644
index 000000000000..6827a79685f2
--- /dev/null
+++ b/www/p5-WWW-iTunesConnect/pkg-descr
@@ -0,0 +1,3 @@
+A Perl5 client interface for Apple's iTunes Connect service.
+
+WWW: http://search.cpan.org/~bfoz/p5-WWW-iTunesConnect/