aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-Bloglines
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-12-02 16:27:50 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-12-02 16:27:50 +0000
commitcd5494c6d09b9dcc22a1db8872288e59dbb91ab9 (patch)
tree2f1f63f3ef46d5587a7342630b6c1f756b853c9c /www/p5-WebService-Bloglines
parent8e0ce6b3ae99ca7ef90a46f833be9b1ef02a299f (diff)
downloadports-cd5494c6d09b9dcc22a1db8872288e59dbb91ab9.tar.gz
ports-cd5494c6d09b9dcc22a1db8872288e59dbb91ab9.zip
add p5-WebService-Bloglines 0.02
Easy-to-use Interface for Bloglines Web Services
Notes
Notes: svn path=/head/; revision=122994
Diffstat (limited to 'www/p5-WebService-Bloglines')
-rw-r--r--www/p5-WebService-Bloglines/Makefile27
-rw-r--r--www/p5-WebService-Bloglines/distinfo2
-rw-r--r--www/p5-WebService-Bloglines/pkg-descr4
-rw-r--r--www/p5-WebService-Bloglines/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/www/p5-WebService-Bloglines/Makefile b/www/p5-WebService-Bloglines/Makefile
new file mode 100644
index 000000000000..77f3b59c0b7b
--- /dev/null
+++ b/www/p5-WebService-Bloglines/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: WebService::Bloglines
+# Date created: Nov 3, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Bloglines
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Easy-to-use Interface for Bloglines Web Services
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Bloglines.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WebService-Bloglines/distinfo b/www/p5-WebService-Bloglines/distinfo
new file mode 100644
index 000000000000..4c2757a7e167
--- /dev/null
+++ b/www/p5-WebService-Bloglines/distinfo
@@ -0,0 +1,2 @@
+MD5 (WebService-Bloglines-0.02.tar.gz) = 820af159a0037501bc1f6577a911c7f1
+SIZE (WebService-Bloglines-0.02.tar.gz) = 4719
diff --git a/www/p5-WebService-Bloglines/pkg-descr b/www/p5-WebService-Bloglines/pkg-descr
new file mode 100644
index 000000000000..4be7be779020
--- /dev/null
+++ b/www/p5-WebService-Bloglines/pkg-descr
@@ -0,0 +1,4 @@
+WebService::Bloglines priovides you an Object Oriented interface for Bloglines
+Web Services (BWS). It currently supports Notifier API and Sync API.
+
+WWW: http://search.cpan.org/dist/WebService-Bloglines/
diff --git a/www/p5-WebService-Bloglines/pkg-plist b/www/p5-WebService-Bloglines/pkg-plist
new file mode 100644
index 000000000000..245af1cfafa0
--- /dev/null
+++ b/www/p5-WebService-Bloglines/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/mach/auto/WebService/Bloglines/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/WebService/Bloglines
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/WebService 2>/dev/null || true
+%%SITE_PERL%%/WebService/Bloglines.pm
+%%SITE_PERL%%/WebService/Bloglines/Entries.pm
+%%SITE_PERL%%/WebService/Bloglines/Subscriptions.pm
+@dirrm %%SITE_PERL%%/WebService/Bloglines
+@unexec rmdir %D/%%SITE_PERL%%/WebService 2>/dev/null || true