aboutsummaryrefslogtreecommitdiff
path: root/www/pear-HTTP_Client
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-02-02 12:42:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-02-02 12:42:48 +0000
commit59ed1e239687131fe78ed3f80d98d399f00beda3 (patch)
treed32212f3c93667bcdb071051bd7cb7c2e5a9e5a1 /www/pear-HTTP_Client
parent98f77420e6db607edfc92472b4ce577d849742a5 (diff)
downloadports-59ed1e239687131fe78ed3f80d98d399f00beda3.tar.gz
ports-59ed1e239687131fe78ed3f80d98d399f00beda3.zip
NEW PORT: www/pear-HTTP_Client (High level HTTP class)
This is my first port with code from PEAR, so I hope I got it right. I based it off of www/pear-HTTP. The HTTP_Client class wraps around HTTP_Request and provides a higher level interface for performing multiple HTTP requests. Features: * Manages cookies and referrers between requests * Handles HTTP redirection * Has methods to set default headers and request parameters * Implements the Subject-Observer design pattern: the base class sends events to listeners that do the response processing. PR: ports/76995 Submitted by: Joseph Scott <joseph@randomnetworks.com>
Notes
Notes: svn path=/head/; revision=127906
Diffstat (limited to 'www/pear-HTTP_Client')
-rw-r--r--www/pear-HTTP_Client/Makefile25
-rw-r--r--www/pear-HTTP_Client/distinfo2
-rw-r--r--www/pear-HTTP_Client/pkg-descr11
3 files changed, 38 insertions, 0 deletions
diff --git a/www/pear-HTTP_Client/Makefile b/www/pear-HTTP_Client/Makefile
new file mode 100644
index 000000000000..3f2a07a259cb
--- /dev/null
+++ b/www/pear-HTTP_Client/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-HTTP_Client
+# Date created: 01 February 2005
+# Whom: Joseph Scott (<joseph@randomnetworks.com>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Client
+PORTVERSION= 1.0.0
+CATEGORIES= www pear
+
+MAINTAINER= joseph@randomnetworks.com
+COMMENT= PEAR classes for high level HTTP requests
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTTP
+FILES= Client.php Client/CookieManager.php
+EXAMPLES= link-checker.php
+_EXAMPLESDIR= examples
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_Client/distinfo b/www/pear-HTTP_Client/distinfo
new file mode 100644
index 000000000000..d37547a52f8e
--- /dev/null
+++ b/www/pear-HTTP_Client/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTTP_Client-1.0.0.tgz) = 4ae6973a6a3663abd9cdbe28ccaacdb4
+SIZE (PEAR/HTTP_Client-1.0.0.tgz) = 6396
diff --git a/www/pear-HTTP_Client/pkg-descr b/www/pear-HTTP_Client/pkg-descr
new file mode 100644
index 000000000000..ff4ac859bf8a
--- /dev/null
+++ b/www/pear-HTTP_Client/pkg-descr
@@ -0,0 +1,11 @@
+The HTTP_Client class wraps around HTTP_Request and provides a higher level
+interface for performing multiple HTTP requests.
+
+Features:
+* Manages cookies and referrers between requests
+* Handles HTTP redirection
+* Has methods to set default headers and request parameters
+* Implements the Subject-Observer design pattern: the base class sends
+ events to listeners that do the response processing.
+
+WWW: http://pear.php.net/package/HTTP_Client/