aboutsummaryrefslogtreecommitdiff
path: root/www/pear-HTTP_Request
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:15:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:15:30 +0000
commit27de4c5c9cd2f878b6093ea35d3220bac6ae930e (patch)
treec735650c050c2222ac75177d0bf0beb99cc3720a /www/pear-HTTP_Request
parent27f3d6050f8f8db80590c0043db846fba24d7524 (diff)
downloadports-27de4c5c9cd2f878b6093ea35d3220bac6ae930e.tar.gz
ports-27de4c5c9cd2f878b6093ea35d3220bac6ae930e.zip
Add pear-HTTP_Request 1.2, PEAR classes providing an easy way to
perform HTTP requests. Approved by: pav (mentor).
Notes
Notes: svn path=/head/; revision=106339
Diffstat (limited to 'www/pear-HTTP_Request')
-rw-r--r--www/pear-HTTP_Request/Makefile26
-rw-r--r--www/pear-HTTP_Request/distinfo2
-rw-r--r--www/pear-HTTP_Request/pkg-descr4
3 files changed, 32 insertions, 0 deletions
diff --git a/www/pear-HTTP_Request/Makefile b/www/pear-HTTP_Request/Makefile
new file mode 100644
index 000000000000..18a8f5a1c79b
--- /dev/null
+++ b/www/pear-HTTP_Request/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-HTTP_Request
+# Date created: 04 April 2004
+# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Request
+PORTVERSION= 1.2
+CATEGORIES= www pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR classes providing an easy way to perform HTTP requests
+
+BUILD_DEPENDS= ${PEARDIR}/Net/URL.php:${PORTSDIR}/net/pear-Net_URL \
+ ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTTP
+FILES= Request.php Request/Listener.php
+EXAMPLES= download-progress.php example.php
+_EXAMPLESDIR= docs
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_Request/distinfo b/www/pear-HTTP_Request/distinfo
new file mode 100644
index 000000000000..16e2626199f0
--- /dev/null
+++ b/www/pear-HTTP_Request/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTTP_Request-1.2.tgz) = 103f7599fc2d4f6be8920340571fd361
+SIZE (PEAR/HTTP_Request-1.2.tgz) = 11856
diff --git a/www/pear-HTTP_Request/pkg-descr b/www/pear-HTTP_Request/pkg-descr
new file mode 100644
index 000000000000..d9ca15aca4c9
--- /dev/null
+++ b/www/pear-HTTP_Request/pkg-descr
@@ -0,0 +1,4 @@
+Supports GET/POST/HEAD/TRACE/PUT/DELETE, Basic authentication, Proxy,
+Proxy Authentication, SSL, redirection etc.
+
+WWW: http://pear.php.net/package/HTTP_Request/