aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_W3C_HTMLValidator
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-29 21:34:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-29 21:34:35 +0000
commita13f30e7b26dc05ded9f6d724b41a5cb63ad74ec (patch)
treea774caef67dc66449f61e3d3f7b614d4fec4067f /www/pear-Services_W3C_HTMLValidator
parent8c6c94bca6eaacde4956d26885261c95d66ad5d4 (diff)
downloadports-a13f30e7b26dc05ded9f6d724b41a5cb63ad74ec.tar.gz
ports-a13f30e7b26dc05ded9f6d724b41a5cb63ad74ec.zip
This package provides an object oriented interface to the API of the
W3 HTML Validator application (http://validator.w3.org/). With this package you can connect to a running instance of the validator and retrieve the validation results (true|false) as well as the errors and warnings for a web page. WWW: http://pear.php.net/package/Services_W3C_HTMLValidator
Notes
Notes: svn path=/head/; revision=191153
Diffstat (limited to 'www/pear-Services_W3C_HTMLValidator')
-rw-r--r--www/pear-Services_W3C_HTMLValidator/Makefile27
-rw-r--r--www/pear-Services_W3C_HTMLValidator/distinfo3
-rw-r--r--www/pear-Services_W3C_HTMLValidator/pkg-descr7
3 files changed, 37 insertions, 0 deletions
diff --git a/www/pear-Services_W3C_HTMLValidator/Makefile b/www/pear-Services_W3C_HTMLValidator/Makefile
new file mode 100644
index 000000000000..eda72e396fd5
--- /dev/null
+++ b/www/pear-Services_W3C_HTMLValidator/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-Services_W3C_HTMLValidator
+# Date created: 2007/04/29
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_W3C_HTMLValidator
+PORTVERSION= 0.2.0
+CATEGORIES= www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= An Object Oriented Interface to the W3C HTML Validator service.
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Services
+FILES= HTMLValidator.php HTMLValidator/Error.php HTMLValidator/Message.php \
+ HTMLValidator/Response.php HTMLValidator/Warning.php
+DOCS= examples/example.html examples/validate_byfile.php \
+ examples/validate_byuri.php examples/validate_fragment.php \
+ examples/validate_responsexml.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_W3C_HTMLValidator/distinfo b/www/pear-Services_W3C_HTMLValidator/distinfo
new file mode 100644
index 000000000000..cba474463f53
--- /dev/null
+++ b/www/pear-Services_W3C_HTMLValidator/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_W3C_HTMLValidator-0.2.0.tgz) = eeeaaccad8fac68f2ce3218544ce69e2
+SHA256 (PEAR/Services_W3C_HTMLValidator-0.2.0.tgz) = aaacd919bb74462e248cf9f8e2c1dcf69b3330e60a988c272c3cdca654a146d8
+SIZE (PEAR/Services_W3C_HTMLValidator-0.2.0.tgz) = 9987
diff --git a/www/pear-Services_W3C_HTMLValidator/pkg-descr b/www/pear-Services_W3C_HTMLValidator/pkg-descr
new file mode 100644
index 000000000000..f91777696f76
--- /dev/null
+++ b/www/pear-Services_W3C_HTMLValidator/pkg-descr
@@ -0,0 +1,7 @@
+This package provides an object oriented interface to the API of the
+W3 HTML Validator application (http://validator.w3.org/). With this
+package you can connect to a running instance of the validator and
+retrieve the validation results (true|false) as well as the errors
+and warnings for a web page.
+
+WWW: http://pear.php.net/package/Services_W3C_HTMLValidator