aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Text_Wiki
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-02-05 01:04:19 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-02-05 01:04:19 +0000
commit5f616e4699f32621e29b9c017d05400ec5c92f69 (patch)
treec3e6cc858480cc2d33a00888f5f067075eb22da9 /www/pear-Text_Wiki
parent2d7f0ec7c5dfa7819a0ac1eb1cad9c94e8d8381c (diff)
downloadports-5f616e4699f32621e29b9c017d05400ec5c92f69.tar.gz
ports-5f616e4699f32621e29b9c017d05400ec5c92f69.zip
New port: www/pear-Text_Wiki
Abstracts parsing and rendering rules for Wiki markup PR: ports/76975 Submitted by: Antônio Carlos Venâncio Júnior <antonio@php.net>
Notes
Notes: svn path=/head/; revision=128056
Diffstat (limited to 'www/pear-Text_Wiki')
-rw-r--r--www/pear-Text_Wiki/Makefile98
-rw-r--r--www/pear-Text_Wiki/distinfo2
-rw-r--r--www/pear-Text_Wiki/pkg-descr3
3 files changed, 103 insertions, 0 deletions
diff --git a/www/pear-Text_Wiki/Makefile b/www/pear-Text_Wiki/Makefile
new file mode 100644
index 000000000000..de973575f357
--- /dev/null
+++ b/www/pear-Text_Wiki/Makefile
@@ -0,0 +1,98 @@
+# Ports collection makefile for: pear-Text_Wiki
+# Date created: 01 February 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text_Wiki
+PORTVERSION= 0.25.0
+CATEGORIES= www devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Abstracts parsing and rendering rules for Wiki markup
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= Text/Wiki/Render/Plain/Wikilink.php \
+ Text/Wiki.php Text/Wiki/Parse.php Text/Wiki/Parse/Default/Anchor.php \
+ Text/Wiki/Parse/Default/Blockquote.php Text/Wiki/Parse/Default/Bold.php \
+ Text/Wiki/Parse/Default/Break.php Text/Wiki/Parse/Default/Center.php \
+ Text/Wiki/Parse/Default/Code.php Text/Wiki/Parse/Default/Colortext.php \
+ Text/Wiki/Parse/Default/Deflist.php Text/Wiki/Parse/Default/Delimiter.php \
+ Text/Wiki/Parse/Default/Embed.php Text/Wiki/Parse/Default/Emphasis.php \
+ Text/Wiki/Parse/Default/Freelink.php Text/Wiki/Parse/Default/Function.php \
+ Text/Wiki/Parse/Default/Heading.php Text/Wiki/Parse/Default/Horiz.php \
+ Text/Wiki/Parse/Default/Html.php Text/Wiki/Parse/Default/Image.php \
+ Text/Wiki/Parse/Default/Include.php Text/Wiki/Parse/Default/Interwiki.php \
+ Text/Wiki/Parse/Default/Italic.php Text/Wiki/Parse/Default/List.php \
+ Text/Wiki/Parse/Default/Newline.php Text/Wiki/Parse/Default/Paragraph.php \
+ Text/Wiki/Parse/Default/Phplookup.php Text/Wiki/Parse/Default/Prefilter.php \
+ Text/Wiki/Parse/Default/Raw.php Text/Wiki/Parse/Default/Revise.php \
+ Text/Wiki/Parse/Default/Strong.php Text/Wiki/Parse/Default/Superscript.php \
+ Text/Wiki/Parse/Default/Table.php Text/Wiki/Parse/Default/Tighten.php \
+ Text/Wiki/Parse/Default/Toc.php Text/Wiki/Parse/Default/Tt.php \
+ Text/Wiki/Parse/Default/Url.php Text/Wiki/Parse/Default/Wikilink.php \
+ Text/Wiki/Render.php Text/Wiki/Render/Xhtml.php \
+ Text/Wiki/Render/Xhtml/Anchor.php Text/Wiki/Render/Xhtml/Blockquote.php \
+ Text/Wiki/Render/Xhtml/Bold.php Text/Wiki/Render/Xhtml/Break.php \
+ Text/Wiki/Render/Xhtml/Center.php Text/Wiki/Render/Xhtml/Code.php \
+ Text/Wiki/Render/Xhtml/Colortext.php Text/Wiki/Render/Xhtml/Deflist.php \
+ Text/Wiki/Render/Xhtml/Delimiter.php Text/Wiki/Render/Xhtml/Embed.php \
+ Text/Wiki/Render/Xhtml/Emphasis.php Text/Wiki/Render/Xhtml/Freelink.php \
+ Text/Wiki/Render/Xhtml/Function.php Text/Wiki/Render/Xhtml/Heading.php \
+ Text/Wiki/Render/Xhtml/Horiz.php Text/Wiki/Render/Xhtml/Html.php \
+ Text/Wiki/Render/Xhtml/Image.php Text/Wiki/Render/Xhtml/Include.php \
+ Text/Wiki/Render/Xhtml/Interwiki.php Text/Wiki/Render/Xhtml/Italic.php \
+ Text/Wiki/Render/Xhtml/List.php Text/Wiki/Render/Xhtml/Newline.php \
+ Text/Wiki/Render/Xhtml/Paragraph.php Text/Wiki/Render/Xhtml/Phplookup.php \
+ Text/Wiki/Render/Xhtml/Prefilter.php Text/Wiki/Render/Xhtml/Raw.php \
+ Text/Wiki/Render/Xhtml/Revise.php Text/Wiki/Render/Xhtml/Strong.php \
+ Text/Wiki/Render/Xhtml/Superscript.php Text/Wiki/Render/Xhtml/Table.php \
+ Text/Wiki/Render/Xhtml/Tighten.php Text/Wiki/Render/Xhtml/Toc.php \
+ Text/Wiki/Render/Xhtml/Tt.php Text/Wiki/Render/Xhtml/Url.php \
+ Text/Wiki/Render/Xhtml/Wikilink.php Text/Wiki/Render/Latex.php \
+ Text/Wiki/Render/Latex/Anchor.php Text/Wiki/Render/Latex/Blockquote.php \
+ Text/Wiki/Render/Latex/Bold.php Text/Wiki/Render/Latex/Break.php \
+ Text/Wiki/Render/Latex/Center.php Text/Wiki/Render/Latex/Code.php \
+ Text/Wiki/Render/Latex/Colortext.php Text/Wiki/Render/Latex/Deflist.php \
+ Text/Wiki/Render/Latex/Delimiter.php Text/Wiki/Render/Latex/Embed.php \
+ Text/Wiki/Render/Latex/Emphasis.php Text/Wiki/Render/Latex/Freelink.php \
+ Text/Wiki/Render/Latex/Function.php Text/Wiki/Render/Latex/Heading.php \
+ Text/Wiki/Render/Latex/Horiz.php Text/Wiki/Render/Latex/Html.php \
+ Text/Wiki/Render/Latex/Image.php Text/Wiki/Render/Latex/Include.php \
+ Text/Wiki/Render/Latex/Interwiki.php Text/Wiki/Render/Latex/Italic.php \
+ Text/Wiki/Render/Latex/List.php Text/Wiki/Render/Latex/Newline.php \
+ Text/Wiki/Render/Latex/Paragraph.php Text/Wiki/Render/Latex/Phplookup.php \
+ Text/Wiki/Render/Latex/Prefilter.php Text/Wiki/Render/Latex/Raw.php \
+ Text/Wiki/Render/Latex/Revise.php Text/Wiki/Render/Latex/Strong.php \
+ Text/Wiki/Render/Latex/Superscript.php Text/Wiki/Render/Latex/Table.php \
+ Text/Wiki/Render/Latex/Tighten.php Text/Wiki/Render/Latex/Toc.php \
+ Text/Wiki/Render/Latex/Tt.php Text/Wiki/Render/Latex/Url.php \
+ Text/Wiki/Render/Latex/Wikilink.php Text/Wiki/Render/Plain.php \
+ Text/Wiki/Render/Plain/Anchor.php Text/Wiki/Render/Plain/Blockquote.php \
+ Text/Wiki/Render/Plain/Bold.php Text/Wiki/Render/Plain/Break.php \
+ Text/Wiki/Render/Plain/Center.php Text/Wiki/Render/Plain/Code.php \
+ Text/Wiki/Render/Plain/Colortext.php Text/Wiki/Render/Plain/Deflist.php \
+ Text/Wiki/Render/Plain/Delimiter.php Text/Wiki/Render/Plain/Embed.php \
+ Text/Wiki/Render/Plain/Emphasis.php Text/Wiki/Render/Plain/Freelink.php \
+ Text/Wiki/Render/Plain/Function.php Text/Wiki/Render/Plain/Heading.php \
+ Text/Wiki/Render/Plain/Horiz.php Text/Wiki/Render/Plain/Html.php \
+ Text/Wiki/Render/Plain/Image.php Text/Wiki/Render/Plain/Include.php \
+ Text/Wiki/Render/Plain/Interwiki.php Text/Wiki/Render/Plain/Italic.php \
+ Text/Wiki/Render/Plain/List.php Text/Wiki/Render/Plain/Newline.php \
+ Text/Wiki/Render/Plain/Paragraph.php Text/Wiki/Render/Plain/Phplookup.php \
+ Text/Wiki/Render/Plain/Prefilter.php Text/Wiki/Render/Plain/Raw.php \
+ Text/Wiki/Render/Plain/Revise.php Text/Wiki/Render/Plain/Strong.php \
+ Text/Wiki/Render/Plain/Superscript.php Text/Wiki/Render/Plain/Table.php \
+ Text/Wiki/Render/Plain/Tighten.php Text/Wiki/Render/Plain/Toc.php \
+ Text/Wiki/Render/Plain/Tt.php Text/Wiki/Render/Plain/Url.php \
+ Text/Wiki/Parse/.keepme
+
+post-extract:
+ ${TOUCH} ${WRKSRC}/Text/Wiki/Parse/.keepme
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Text_Wiki/distinfo b/www/pear-Text_Wiki/distinfo
new file mode 100644
index 000000000000..2ac8da31bb95
--- /dev/null
+++ b/www/pear-Text_Wiki/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Text_Wiki-0.25.0.tgz) = 0921881a6e8c87fedaac900589775d14
+SIZE (PEAR/Text_Wiki-0.25.0.tgz) = 46425
diff --git a/www/pear-Text_Wiki/pkg-descr b/www/pear-Text_Wiki/pkg-descr
new file mode 100644
index 000000000000..54b4ea09417a
--- /dev/null
+++ b/www/pear-Text_Wiki/pkg-descr
@@ -0,0 +1,3 @@
+Abstracts parsing and rendering rules for Wiki markup in structured plain text.
+
+WWW: http://pear.php.net/package/Text_Wiki/