aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-APC
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-26 21:44:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-26 21:44:16 +0000
commit85060840079d5bb4405035439a5853912c43785c (patch)
treef0596d16ba8f39537e006aaa1d8f79d94be4d7fe /www/pecl-APC
parent6dac0b1a8673def1e9f25e4a92bb9ba204e59dbe (diff)
downloadports-85060840079d5bb4405035439a5853912c43785c.tar.gz
ports-85060840079d5bb4405035439a5853912c43785c.zip
- Reflect the fact that APC is now a PECL package
- Take maintainership PR: ports/78019 Submitted by: Marcus Grando <marcus@corp.grupos.com.br> Repocopy by: marcus
Notes
Notes: svn path=/head/; revision=129860
Diffstat (limited to 'www/pecl-APC')
-rw-r--r--www/pecl-APC/Makefile55
-rw-r--r--www/pecl-APC/distinfo4
-rw-r--r--www/pecl-APC/files/pkg-message.in (renamed from www/pecl-APC/pkg-message)12
-rw-r--r--www/pecl-APC/pkg-descr2
-rw-r--r--www/pecl-APC/pkg-plist7
5 files changed, 35 insertions, 45 deletions
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index 09b35be12153..d5a941593032 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -7,47 +7,42 @@
PORTNAME= APC
PORTVERSION= 2.0.4
-CATEGORIES= www pear
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= marcus@corp.grupos.com.br
COMMENT= Alternative PHP Cache
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
USE_PHP= yes
USE_PHPIZE= yes
+USE_PHPEXT= yes
+PHP_MODNAME= apc
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ARGS= --enable-apc
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+OPTIONS= MMAP "Enable mmap" off
+
+.if !defined(WITHOUT_MMAP)
+CONFIGURE_ARGS+= --enable-mmap
+.endif
-.if exists(${LOCALBASE}/bin/php-config)
-EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
- "s:${PHP_BASE}/::"
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
.endif
-PHP_DIR?= ${LOCALBASE}/etc
-PHP_INI= ${PHP_DIR}/php.ini
-PLIST_SUB+= EXTDIR=${EXT_DIR}
-DOCS= CHANGELOG INSTALL NOTICE
-
-post-install-script:
- @${STRIP_CMD} ${PHP_BASE}/${EXT_DIR}/apc.so
- @if [ ! -f ${PHP_INI} ]; then \
- ${ECHO_MSG} "===> Creating ${PHP_INI} for PHP" ; \
- ${CP} -p ${PHP_INI}-dist ${PHP_INI} ; \
- fi
+
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/NOTICE ${DOCSDIR}
.endif
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE} | \
- ${SED} -e "s:/usr/local/etc/php.ini:${PHP_INI}:"
- @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pecl-APC/distinfo b/www/pecl-APC/distinfo
index f50e9f8d9a7d..49a453a60f5d 100644
--- a/www/pecl-APC/distinfo
+++ b/www/pecl-APC/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/APC-2.0.4.tgz) = 4962f05bc752e3cfa1f662bbdfa33605
-SIZE (PEAR/APC-2.0.4.tgz) = 44606
+MD5 (PECL/APC-2.0.4.tgz) = 4962f05bc752e3cfa1f662bbdfa33605
+SIZE (PECL/APC-2.0.4.tgz) = 44606
diff --git a/www/pecl-APC/pkg-message b/www/pecl-APC/files/pkg-message.in
index 0de322a03cfd..4eaba38d6050 100644
--- a/www/pecl-APC/pkg-message
+++ b/www/pecl-APC/files/pkg-message.in
@@ -1,13 +1,15 @@
************************************************************************
-Do not forget to configure your /usr/local/etc/php.ini file:
-add the line:
+You may edit %%LOCALBASE%%/etc/php.ini to change this variables:
-extension="apc.so"
+apc.enabled="1"
+ ^^^ -> Default value
-in the section "Dynamic Extensions".
+apc.shm_size="30"
+ ^^^^ -> Default value
+
+* More information on %%DOCSDIR%%/INSTALL
Then restart your web server and consult the output of phpinfo().
If there is an informational section for APC, the installation was
successful.
************************************************************************
-
diff --git a/www/pecl-APC/pkg-descr b/www/pecl-APC/pkg-descr
index 9a49a282355b..588547de5a3c 100644
--- a/www/pecl-APC/pkg-descr
+++ b/www/pecl-APC/pkg-descr
@@ -3,4 +3,4 @@ APC is the Alternative PHP Cache.
It was conceived of to provide a free, open, and robust framework for
caching and optimizing PHP intermediate code.
-WWW: http://pear.php.net/package/APC
+WWW: http://pecl.php.net/package/APC
diff --git a/www/pecl-APC/pkg-plist b/www/pecl-APC/pkg-plist
deleted file mode 100644
index 5dbea02fc4c3..000000000000
--- a/www/pecl-APC/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-%%EXTDIR%%/apc.so
-%%PKGREGDIR%%/package.xml
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NOTICE
-@dirrm %%PKGREGDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%