aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-pecl_http
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-06 15:34:44 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-06 15:34:44 +0000
commitec123a3468816cce74c287c41440203f37f94c32 (patch)
treed52dd066d8ab9d08e1556ea57d229ea07ef06ef9 /www/pecl-pecl_http
parentcf3ef2f9915497b20e228c638be270b482439981 (diff)
downloadports-ec123a3468816cce74c287c41440203f37f94c32.tar.gz
ports-ec123a3468816cce74c287c41440203f37f94c32.zip
Add pecl-pecl_http 0.22.0, a PHP extension which provides extended HTTP
request/response handling. PR: ports/92827 Submitted by: Alexander Zhuravlev <zaa@zaa.pp.ru>
Notes
Notes: svn path=/head/; revision=155339
Diffstat (limited to 'www/pecl-pecl_http')
-rw-r--r--www/pecl-pecl_http/Makefile59
-rw-r--r--www/pecl-pecl_http/distinfo3
-rw-r--r--www/pecl-pecl_http/pkg-descr16
3 files changed, 78 insertions, 0 deletions
diff --git a/www/pecl-pecl_http/Makefile b/www/pecl-pecl_http/Makefile
new file mode 100644
index 000000000000..55c654d664b9
--- /dev/null
+++ b/www/pecl-pecl_http/Makefile
@@ -0,0 +1,59 @@
+# Ports collection makefile for: pecl-pecl_http
+# Date created: 2005-12-19
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pecl_http
+PORTVERSION= 0.22.0
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= A PHP extension which provides extended HTTP request/response handling
+
+USE_PHP= session zlib
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+PHP_MODNAME= http
+
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/hash.so:${PORTSDIR}/security/pecl-hash
+
+CONFIGURE_ARGS= --enable-http
+
+OPTIONS= CURL "Enable cURL HTTP requests" on \
+ MAGIC_MIME "Enable response content type guessing" off \
+ ZLIB_COMPRESSION "Enable support for encoded message bodies" on
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build on FreeBSD <= 4.x
+.endif
+
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+=--with-http-curl-requests=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-http-curl-requests
+.endif
+
+.if defined(WITH_MAGIC_MIME)
+LIB_DEPENDS+= magic.1:${PORTSDIR}/sysutils/file
+CONFIGURE_ARGS+=--with-http-magic-mime=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-http-magic-mime
+.endif
+
+.if defined(WITH_ZLIB_COMPRESSION)
+CONFIGURE_ARGS+=--with-http-zlib-compression=/usr
+.else
+CONFIGURE_ARGS+=--without-http-zlib-compression
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/pecl-pecl_http/distinfo b/www/pecl-pecl_http/distinfo
new file mode 100644
index 000000000000..f7681d12384a
--- /dev/null
+++ b/www/pecl-pecl_http/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/pecl_http-0.22.0.tgz) = 849d667960cafa06787baac03c873fbf
+SHA256 (PECL/pecl_http-0.22.0.tgz) = 7d6901c5858dde4c39740afb789ad13abdf4a79c69911ec6100d1cfdfb2d7bbd
+SIZE (PECL/pecl_http-0.22.0.tgz) = 163358
diff --git a/www/pecl-pecl_http/pkg-descr b/www/pecl-pecl_http/pkg-descr
new file mode 100644
index 000000000000..ea74d729ac74
--- /dev/null
+++ b/www/pecl-pecl_http/pkg-descr
@@ -0,0 +1,16 @@
+This HTTP extension aims to provide a convenient and powerful
+set of functionality for one of PHPs major applications.
+
+It eases handling of HTTP urls, dates, redirects, headers and
+messages, provides means for negotiation of clients preferred
+language and charset, as well as a convenient way to send any
+arbitrary data with caching and resuming capabilities.
+
+It provides powerful request functionality, if built with CURL
+support. Parallel requests are available for PHP-5 and greater.
+
+PHP-5 classes:
+HttpUtil, HttpMessage, HttpRequest, HttpRequestPool;
+HttpResponse (PHP-5.1)
+
+WWW: http://pecl.php.net/package/pecl_http/