aboutsummaryrefslogtreecommitdiff
path: root/www/php-templates
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-05-23 08:03:17 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-05-23 08:03:17 +0000
commitf443020df1b5ef040df488063f95ec25929bc590 (patch)
tree41917cf54573644c1ce629f98b9dba5dbb3313d4 /www/php-templates
parent8895120fcad72def77598ac107f8b22e7b0cbad9 (diff)
downloadports-f443020df1b5ef040df488063f95ec25929bc590.tar.gz
ports-f443020df1b5ef040df488063f95ec25929bc590.zip
Fix build with php 5.4 and drop maintainership.
Notes
Notes: svn path=/head/; revision=297271
Diffstat (limited to 'www/php-templates')
-rw-r--r--www/php-templates/Makefile12
-rw-r--r--www/php-templates/files/patch-templates.c11
2 files changed, 16 insertions, 7 deletions
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index ec3e5ed98261..299dd8954f89 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -8,15 +8,15 @@
PORTNAME= php-templates
PORTVERSION= 1.7.2
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.7 \
- SF/${PORTNAME}/${PORTNAME}-doc/html
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.7:ext \
+ SF/${PORTNAME}/${PORTNAME}-doc/html:doc
DISTNAME= php_templates-${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:ext
.if !defined(NOPORTDOCS)
-DISTFILES+= php_templates-doc-eng-1.1${EXTRACT_SUFX}
+DISTFILES+= php_templates-doc-eng-1.1${EXTRACT_SUFX}:doc
.endif
-MAINTAINER= ale@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A template framework for PHP
WRKSRC= ${WRKDIR}/templates
@@ -24,8 +24,6 @@ USE_DOS2UNIX= yes
USE_PHP= yes
USE_PHPIZE= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-templates=shared
diff --git a/www/php-templates/files/patch-templates.c b/www/php-templates/files/patch-templates.c
new file mode 100644
index 000000000000..9b9e870e6213
--- /dev/null
+++ b/www/php-templates/files/patch-templates.c
@@ -0,0 +1,11 @@
+--- templates.c.orig 2012-05-23 09:56:51.000000000 +0200
++++ templates.c 2012-05-23 09:57:08.000000000 +0200
+@@ -48,7 +48,7 @@
+ int le_templates;
+
+ /* {{{ templates_functions[] */
+-function_entry templates_functions[] = {
++zend_function_entry templates_functions[] = {
+ PHP_FE(tmpl_open, NULL)
+ PHP_FE(tmpl_load, NULL)
+ PHP_FE(tmpl_close, NULL)