aboutsummaryrefslogtreecommitdiff
path: root/www/phpSysInfo
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2007-01-31 21:38:39 +0000
committerShaun Amott <shaun@FreeBSD.org>2007-01-31 21:38:39 +0000
commita2d18f70a7c03f7dbdfdd9ced061c66ce2dd2b1a (patch)
tree7d86942c700e50738cc92ae52598516a83be207d /www/phpSysInfo
parentaeabe7158bea774b927052aca6f68442187fa39e (diff)
downloadports-a2d18f70a7c03f7dbdfdd9ced061c66ce2dd2b1a.tar.gz
ports-a2d18f70a7c03f7dbdfdd9ced061c66ce2dd2b1a.zip
A bug present in PHP 5.2.0 causes a segfault in phpSysInfo; add a patch
that works around this. Submitted by: Zoltan Frombach Obtained from: http://sourceforge.net/forum/forum.php?thread_id=1656641&forum_id=10
Notes
Notes: svn path=/head/; revision=183814
Diffstat (limited to 'www/phpSysInfo')
-rw-r--r--www/phpSysInfo/Makefile1
-rw-r--r--www/phpSysInfo/files/patch-pre5.2.1-segfault.diff11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/phpSysInfo/Makefile b/www/phpSysInfo/Makefile
index 78cd63827633..cdfb91e3c9ea 100644
--- a/www/phpSysInfo/Makefile
+++ b/www/phpSysInfo/Makefile
@@ -6,6 +6,7 @@
PORTNAME= phpSysInfo
PORTVERSION= 2.5.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}
diff --git a/www/phpSysInfo/files/patch-pre5.2.1-segfault.diff b/www/phpSysInfo/files/patch-pre5.2.1-segfault.diff
new file mode 100644
index 000000000000..f3282fd26c3e
--- /dev/null
+++ b/www/phpSysInfo/files/patch-pre5.2.1-segfault.diff
@@ -0,0 +1,11 @@
+--- includes/xml/filesystems.php.orig
++++ includes/xml/filesystems.php
+@@ -85,7 +85,7 @@
+ . " <td align=\"" . $textdir['right'] . "\" valign=\"top\"><font size=\"-1\"><b>" . $text['size'] . "</b></font></td>\n </tr>\n";
+ for( $i = 1, $max = sizeof( $XPath->getDataParts( "/phpsysinfo/FileSystem" ) ); $i < $max; $i++ ) {
+ if( $XPath->match( "/phpsysinfo/FileSystem/Mount[" . $i . "]/MountPointID" ) ) {
+- if( ! $XPath->match( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Options" ) || ! stristr( $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Options" ), "bind" ) ) {
++ if( ! $XPath->match( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Options" ) ) {
+ if( ! in_array( $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Device/Name" ), $arrCounteddevlist ) ) {
+ $arrSum['size'] += $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Size" );
+ $arrSum['used'] += $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Used" );