aboutsummaryrefslogtreecommitdiff
path: root/www/phpmp
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2007-02-27 03:45:35 +0000
committerKevin Lo <kevlo@FreeBSD.org>2007-02-27 03:45:35 +0000
commite43ae6e65e824cbd816ab3469576d10e83f613bb (patch)
tree5830295f3287ba204ca5e28113ea0636e9329742 /www/phpmp
parent1385e9898b249d464f89f297193b15d9124f5fe8 (diff)
downloadports-e43ae6e65e824cbd816ab3469576d10e83f613bb.tar.gz
ports-e43ae6e65e824cbd816ab3469576d10e83f613bb.zip
Initial import of phpmp 0.11.0.
phpMp is a web interface for Music Player Daemon (MPD) which allows remote control of MPD. For example, to control a housewide stereo system from multiple locations.
Notes
Notes: svn path=/head/; revision=186055
Diffstat (limited to 'www/phpmp')
-rw-r--r--www/phpmp/Makefile29
-rw-r--r--www/phpmp/distinfo3
-rw-r--r--www/phpmp/pkg-descr5
-rw-r--r--www/phpmp/pkg-plist30
4 files changed, 67 insertions, 0 deletions
diff --git a/www/phpmp/Makefile b/www/phpmp/Makefile
new file mode 100644
index 000000000000..5f1fd9dcfee3
--- /dev/null
+++ b/www/phpmp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: phpmp
+# Date created: 2007-02-27
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpmp
+PORTVERSION= 0.11.0
+CATEGORIES= www
+MASTER_SITES= http://mercury.chem.pitt.edu/~shank/
+DISTNAME= phpMp-${PORTVERSION}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A web interface for music player daemon
+
+NO_BUILD= YES
+USE_PHP= sockets
+
+PHPMP?= www/phpmp
+PLIST_SUB+= PHPMP=${PHPMP}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${PHPMP}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${PHPMP}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPMP}
+ @${CHMOD} -R 755 ${PREFIX}/${PHPMP}
+
+.include <bsd.port.mk>
diff --git a/www/phpmp/distinfo b/www/phpmp/distinfo
new file mode 100644
index 000000000000..6b107c34a437
--- /dev/null
+++ b/www/phpmp/distinfo
@@ -0,0 +1,3 @@
+MD5 (phpMp-0.11.0.tar.gz) = e61cf003a8dff994dc3d0ec82bd962f2
+SHA256 (phpMp-0.11.0.tar.gz) = 7f2a168632839f2c476275a1cff41ea3295b9ebbe85e4e3cc691609258ab0103
+SIZE (phpMp-0.11.0.tar.gz) = 20886
diff --git a/www/phpmp/pkg-descr b/www/phpmp/pkg-descr
new file mode 100644
index 000000000000..113bdf5c8b32
--- /dev/null
+++ b/www/phpmp/pkg-descr
@@ -0,0 +1,5 @@
+phpMp is a web interface for Music Player Daemon (MPD) which allows
+remote control of MPD. For example, to control a housewide stereo system
+from multiple locations.
+
+WWW: http://www.musicpd.org/phpMp.shtml
diff --git a/www/phpmp/pkg-plist b/www/phpmp/pkg-plist
new file mode 100644
index 000000000000..a4697638a6b1
--- /dev/null
+++ b/www/phpmp/pkg-plist
@@ -0,0 +1,30 @@
+%%PHPMP%%/COPYING
+%%PHPMP%%/ChangeLog
+%%PHPMP%%/INSTALL
+%%PHPMP%%/README
+%%PHPMP%%/TODO
+%%PHPMP%%/config.php
+%%PHPMP%%/find.php
+%%PHPMP%%/find_body.php
+%%PHPMP%%/index.php
+%%PHPMP%%/info.php
+%%PHPMP%%/info2html.php
+%%PHPMP%%/login.php
+%%PHPMP%%/login_body.php
+%%PHPMP%%/main.php
+%%PHPMP%%/main_body.php
+%%PHPMP%%/playlist.php
+%%PHPMP%%/playlist_body.php
+%%PHPMP%%/search.php
+%%PHPMP%%/search_body.php
+%%PHPMP%%/sort.php
+%%PHPMP%%/stats.php
+%%PHPMP%%/stats_body.php
+%%PHPMP%%/stream.php
+%%PHPMP%%/stream_body.php
+%%PHPMP%%/theme.php
+%%PHPMP%%/transparent.gif
+%%PHPMP%%/update.php
+%%PHPMP%%/update_body.php
+%%PHPMP%%/utils.php
+@dirrmtry %%PHPMP%%