aboutsummaryrefslogtreecommitdiff
path: root/www/preferential
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-07-03 06:41:13 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-07-03 06:41:13 +0000
commit25d677010b792e0d7b0d8fa845a7e5d41776e220 (patch)
treeadf2bfaaab44b5cc5d2c80d6a5995fb23191765d /www/preferential
parent4193e3bf7ec4908d2875d8d05449c1bab070127f (diff)
downloadports-25d677010b792e0d7b0d8fa845a7e5d41776e220.tar.gz
ports-25d677010b792e0d7b0d8fa845a7e5d41776e220.zip
Adding www/preferential & www/preferential-firefox, GUI interface to
view and edit all Mozilla / Firefox prefs. PR: ports/63237
Notes
Notes: svn path=/head/; revision=112834
Diffstat (limited to 'www/preferential')
-rw-r--r--www/preferential/Makefile26
-rw-r--r--www/preferential/distinfo2
-rw-r--r--www/preferential/pkg-descr5
-rw-r--r--www/preferential/pkg-plist2
4 files changed, 35 insertions, 0 deletions
diff --git a/www/preferential/Makefile b/www/preferential/Makefile
new file mode 100644
index 000000000000..86778d03b99d
--- /dev/null
+++ b/www/preferential/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: preferential
+# Date created: Tue Oct 28, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME?= preferential
+PORTVERSION= 0.6.1a
+CATEGORIES= www
+MASTER_SITES= http://downloads.mozdev.org/preferential/versions/ \
+ http://mozdev.mirrors.nyphp.org/preferential/versions/
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER?= ports@FreeBSD.org
+COMMENT?= GUI interface to view & edit all Mozilla prefs
+
+USE_X_PREFIX= yes # Cannot be included after <bsd.port.pre.mk>.
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozex/Makefile.xpi"
+
+do-install:
+ @${INSTALL_DATA} ${WRKDIR}/preferential.jar ${MOZDIR}/chrome
+
+.include <bsd.port.post.mk>
diff --git a/www/preferential/distinfo b/www/preferential/distinfo
new file mode 100644
index 000000000000..00b858320f34
--- /dev/null
+++ b/www/preferential/distinfo
@@ -0,0 +1,2 @@
+MD5 (preferential-0.6.1a/preferential-0.6.1a.xpi) = 0630fa253f4b328f890251fab1e8c55a
+SIZE (preferential-0.6.1a/preferential-0.6.1a.xpi) = 76432
diff --git a/www/preferential/pkg-descr b/www/preferential/pkg-descr
new file mode 100644
index 000000000000..f413839b2503
--- /dev/null
+++ b/www/preferential/pkg-descr
@@ -0,0 +1,5 @@
+The Preferential project aims to provide all users of Gecko browsers
+(eg. Mozilla, Firefox) with a simple, accessible GUI that allows the
+modification of any preference set within that browser environment.
+
+WWW: http://preferential.mozdev.org/
diff --git a/www/preferential/pkg-plist b/www/preferential/pkg-plist
new file mode 100644
index 000000000000..c7f67cfb7203
--- /dev/null
+++ b/www/preferential/pkg-plist
@@ -0,0 +1,2 @@
+%%MOZDIR%%/chrome/preferential.jar
+%%MOZDIR%%/chrome/overlayinfo/browser/content/overlays.rdf