aboutsummaryrefslogtreecommitdiff
path: root/www/privoxy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-15 20:48:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-15 20:48:23 +0000
commitc102162b3ad647d08a0df0d3bb3581fe444bc071 (patch)
treec1cd84639798cb3a750a0f60224975a1bdcd0200 /www/privoxy
parenta8758fe8aae5a96d649be30e29fe66572a73a38f (diff)
downloadports-c102162b3ad647d08a0df0d3bb3581fe444bc071.tar.gz
ports-c102162b3ad647d08a0df0d3bb3581fe444bc071.zip
- Fix rc script
Reported by: Adam McMaster <adam@moosoft.net>
Notes
Notes: svn path=/head/; revision=148403
Diffstat (limited to 'www/privoxy')
-rw-r--r--www/privoxy/Makefile7
-rw-r--r--www/privoxy/files/privoxy.sh.in4
2 files changed, 7 insertions, 4 deletions
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index b02712789fbe..780ef9039e69 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= privoxy
PORTVERSION= 3.0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ijbswa
@@ -32,7 +32,7 @@ MAN1= privoxy.1
post-patch:
${REINPLACE_CMD} \
-e 's,^\(confdir\) \.,\1 ${PREFIX}/etc/privoxy,' \
- -e 's,^\(logdir\) \.,\1 /tmp,' \
+ -e 's,^\(logdir\) \.,\1 /var/log/privoxy,' \
-e 's,^\(actionsfile standard\),#\1,' \
-e 's,^\(actionsfile user\),#\1,' \
${WRKSRC}/config
@@ -66,6 +66,9 @@ post-install:
${TOUCH} /var/log/jarfile
${CHOWN} privoxy:privoxy /var/log/jarfile
${CHMOD} 0600 /var/log/jarfile
+ ${TOUCH} /var/run/privoxy
+ ${CHOWN} privoxy:privoxy /var/run/privoxy
+ ${CHMOD} 0600 /var/run/privoxy
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/privoxy/files/privoxy.sh.in b/www/privoxy/files/privoxy.sh.in
index 3080acb75218..f29bb8c32b2a 100644
--- a/www/privoxy/files/privoxy.sh.in
+++ b/www/privoxy/files/privoxy.sh.in
@@ -11,7 +11,7 @@
#
privoxy_enable=${privoxy_enable-"NO"}
privoxy_flags=${privoxy_flags-""}
-privoxy_pidfile=${privoxy_pidfile-"/var/run/privoxy.pid"}
+privoxy_pidfile=${privoxy_pidfile-"/var/run/privoxy/privoxy.pid"}
. %%RC_SUBR%%
@@ -30,7 +30,7 @@ privoxy_start()
echo "${name} is already running"
else
echo "Starting ${name}."
- su -m privoxy -c '${command} ${privoxy_flags} ${configfile} --pidfile ${pidfile}' \
+ su -m privoxy -c "${command} ${privoxy_flags} ${configfile} --pidfile ${pidfile}" \
1>/dev/null 2>&1
fi
}