aboutsummaryrefslogtreecommitdiff
path: root/www/py-beautifulsoup
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-16 21:51:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-16 21:51:18 +0000
commita6e3fbcd929f5e0ad88adcd499d0ba3d5417beaf (patch)
tree39897bb556feb23b16535b1f34d5c481787c8d51 /www/py-beautifulsoup
parentb047c30d2fdbc6ec36948573311eae996d20c3b1 (diff)
downloadports-a6e3fbcd929f5e0ad88adcd499d0ba3d5417beaf.tar.gz
ports-a6e3fbcd929f5e0ad88adcd499d0ba3d5417beaf.zip
Beautiful Soup parses arbitrarily invalid XML- or HTML-like substance
into a tree representation. It provides methods and Pythonic idioms that make it easy to search and modify the tree. PR: ports/83531 Submitted by: Mike Meyer <mwm@mired.org>
Notes
Notes: svn path=/head/; revision=139369
Diffstat (limited to 'www/py-beautifulsoup')
-rw-r--r--www/py-beautifulsoup/Makefile23
-rw-r--r--www/py-beautifulsoup/distinfo2
-rw-r--r--www/py-beautifulsoup/pkg-descr12
-rw-r--r--www/py-beautifulsoup/pkg-plist6
4 files changed, 43 insertions, 0 deletions
diff --git a/www/py-beautifulsoup/Makefile b/www/py-beautifulsoup/Makefile
new file mode 100644
index 000000000000..95ba52d31b54
--- /dev/null
+++ b/www/py-beautifulsoup/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: beautifulsoup
+# Date created: 15 July 2005
+# Whom: Mike Meyer <mwm@mired.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beautifulsoup
+PORTVERSION= 2.1.0
+CATEGORIES= www python
+MASTER_SITES= http://www.crummy.com/software/BeautifulSoup/download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= BeautifulSoup
+
+MAINTAINER= mwm@mired.org
+COMMENT= HTML/XML Parser for Python
+
+WRKSRC= ${WRKDIR}/${DISTNAME}-${PORTVERSION}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-beautifulsoup/distinfo b/www/py-beautifulsoup/distinfo
new file mode 100644
index 000000000000..337b3c03a57d
--- /dev/null
+++ b/www/py-beautifulsoup/distinfo
@@ -0,0 +1,2 @@
+MD5 (BeautifulSoup.tar.gz) = 06cca36d76601fa43ecfaf18fcf11985
+SIZE (BeautifulSoup.tar.gz) = 15657
diff --git a/www/py-beautifulsoup/pkg-descr b/www/py-beautifulsoup/pkg-descr
new file mode 100644
index 000000000000..eb0ab5affd47
--- /dev/null
+++ b/www/py-beautifulsoup/pkg-descr
@@ -0,0 +1,12 @@
+Beautiful Soup parses arbitrarily invalid XML- or HTML-like substance
+into a tree representation. It provides methods and Pythonic idioms
+that make it easy to search and modify the tree.
+
+A well-formed XML/HTML document will yield a well-formed data
+structure. An ill-formed XML/HTML document will yield a
+correspondingly ill-formed data structure. If your document is only
+locally well-formed, you can use this library to find and process the
+well-formed part of it. The BeautifulSoup class has heuristics for
+obtaining a sensible parse tree in the face of common HTML errors.
+
+WWW: http://www.crummy.com/software/BeautifulSoup/
diff --git a/www/py-beautifulsoup/pkg-plist b/www/py-beautifulsoup/pkg-plist
new file mode 100644
index 000000000000..e8e0f66c96b0
--- /dev/null
+++ b/www/py-beautifulsoup/pkg-plist
@@ -0,0 +1,6 @@
+lib/%%PYTHON_VERSION%%/site-packages/BeautifulSoup.py
+lib/%%PYTHON_VERSION%%/site-packages/BeautifulSoup.pyc
+lib/%%PYTHON_VERSION%%/site-packages/BeautifulSoup.pyo
+lib/%%PYTHON_VERSION%%/site-packages/BeautifulSoupTests.py
+lib/%%PYTHON_VERSION%%/site-packages/BeautifulSoupTests.pyc
+lib/%%PYTHON_VERSION%%/site-packages/BeautifulSoupTests.pyo