aboutsummaryrefslogtreecommitdiff
path: root/www/py-funkload
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /www/py-funkload
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Notes
Notes: svn path=/head/; revision=196700
Diffstat (limited to 'www/py-funkload')
-rw-r--r--www/py-funkload/Makefile18
-rw-r--r--www/py-funkload/pkg-plist4
2 files changed, 3 insertions, 19 deletions
diff --git a/www/py-funkload/Makefile b/www/py-funkload/Makefile
index 59551b58cfe0..4ba6c354999d 100644
--- a/www/py-funkload/Makefile
+++ b/www/py-funkload/Makefile
@@ -16,28 +16,14 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= FunkLoad is a functional and load web tester
-BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
- ${PYTHON_SITELIBDIR}/docutils/__init__.py:${PORTSDIR}/textproc/py-docutils \
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/docutils/__init__.py:${PORTSDIR}/textproc/py-docutils \
${PYTHON_SITELIBDIR}/gdchart.so:${PORTSDIR}/graphics/py-gdchart \
${PYTHON_SITELIBDIR}/webunit/__init__.py:${PORTSDIR}/www/py-webunit \
${PYXML} \
tcpwatch.py:${PORTSDIR}/net/tcpwatch
USE_PYTHON= 2.4+
-USE_PYDISTUTILS= yes
-
-EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
-
-PYDISTUTILS_BUILD_TARGET= bdist_egg
-PYDISTUTILS_INSTALL_TARGET= easy_install
-PYDISTUTILS_INSTALLARGS= -O 1 -N -S ${PYTHON_SITELIBDIR} ${WRKSRC}/dist/${PYFUNKLOAD_EGG}
-
-PYFUNKLOAD_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
-
-PLIST_SUB+= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
- PYFUNKLOAD_EGG=${PYFUNKLOAD_EGG} \
- PYFUNKLOAD_EGG_VER="${PORTNAME}==${PORTVERSION}"
+USE_PYDISTUTILS= easy_install
DOCSDIR= ${TARGETDIR}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
diff --git a/www/py-funkload/pkg-plist b/www/py-funkload/pkg-plist
index b26f8aa30408..f1916e775384 100644
--- a/www/py-funkload/pkg-plist
+++ b/www/py-funkload/pkg-plist
@@ -1,6 +1,4 @@
-@unexec %%EASY_INSTALL_CMD%% -q -m -S %D/%%PYTHON_SITELIBDIR%% %%PYFUNKLOAD_EGG_VER%%
-%%PYTHON_SITELIBDIR%%/%%PYFUNKLOAD_EGG%%
-@exec %%EASY_INSTALL_CMD%% -q -N -S %D/%%PYTHON_SITELIBDIR%% %%PYFUNKLOAD_EGG_VER%%
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
bin/fl-build-report
bin/fl-credential-ctl
bin/fl-import-from-tm-recorder