aboutsummaryrefslogtreecommitdiff
path: root/www/py-libsass/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2017-02-10 19:44:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2017-02-10 19:44:49 +0000
commitfddd8582f43de96c12be61989a2be83a5e1cffc3 (patch)
tree5646d166c0ff2508fd524da1963aafee7ee0ff13 /www/py-libsass/Makefile
parent70e35c5c2c7d59609b2889bd27220f03a05b4619 (diff)
downloadports-fddd8582f43de96c12be61989a2be83a5e1cffc3.tar.gz
ports-fddd8582f43de96c12be61989a2be83a5e1cffc3.zip
Add new port www/py-libsass
A simple Python extension module sass which is binding Libsass (written in C/C++ by Hampton Catlin and Aaron Leung). WWW: https://pypi.python.org/pypi/libsass PR: 216961 Submitted by: yuri@rawbw.com Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9531
Notes
Notes: svn path=/head/; revision=433823
Diffstat (limited to 'www/py-libsass/Makefile')
-rw-r--r--www/py-libsass/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/www/py-libsass/Makefile b/www/py-libsass/Makefile
new file mode 100644
index 000000000000..32195d1acef2
--- /dev/null
+++ b/www/py-libsass/Makefile
@@ -0,0 +1,20 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= libsass
+PORTVERSION= 0.12.3
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Straightforward binding of libsass for Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>