aboutsummaryrefslogtreecommitdiff
path: root/www/py-rssdler
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-19 05:56:15 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-19 05:56:15 +0000
commit3f05fc4f46aace751b13ce253365e28707102c73 (patch)
tree206d8197b4186ad8c208e9db9e86bc5d52255e6e /www/py-rssdler
parent817f70f41781d6d400afff58e17f59042ce45792 (diff)
downloadports-3f05fc4f46aace751b13ce253365e28707102c73.tar.gz
ports-3f05fc4f46aace751b13ce253365e28707102c73.zip
- Regenerate patches at maintainer/submitter request to be by function
name instead of file name. PR: ports/151339 Requested by swell.k@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=263253
Diffstat (limited to 'www/py-rssdler')
-rw-r--r--www/py-rssdler/Makefile2
-rw-r--r--www/py-rssdler/files/patch-_main (renamed from www/py-rssdler/files/patch-rssdler.py)6
-rw-r--r--www/py-rssdler/files/patch-main14
3 files changed, 19 insertions, 3 deletions
diff --git a/www/py-rssdler/Makefile b/www/py-rssdler/Makefile
index eff548290e60..29b70f1c62e1 100644
--- a/www/py-rssdler/Makefile
+++ b/www/py-rssdler/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rssdler
PORTVERSION= 0.4.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-rssdler/files/patch-rssdler.py b/www/py-rssdler/files/patch-_main
index aa94ab3cb40a..5f07dd60ab26 100644
--- a/www/py-rssdler/files/patch-rssdler.py
+++ b/www/py-rssdler/files/patch-_main
@@ -1,5 +1,7 @@
---- ./rssdler.py.orig 2010-10-10 03:58:44.112133159 +0000
-+++ ./rssdler.py 2010-10-10 03:59:10.937002223 +0000
+Index: rssdler.py
+===================================================================
+--- rssdler.py (revision 169)
++++ rssdler.py (working copy)
@@ -2180,6 +2180,7 @@
elif param == "--purge-saved": _action = 'purge-saved'
elif param == "--comment-config": _action = 'comment-config'
diff --git a/www/py-rssdler/files/patch-main b/www/py-rssdler/files/patch-main
new file mode 100644
index 000000000000..d45b908b33a7
--- /dev/null
+++ b/www/py-rssdler/files/patch-main
@@ -0,0 +1,14 @@
+Index: rssdler.py
+===================================================================
+--- rssdler.py (revision 169)
++++ rssdler.py (working copy)
+@@ -2085,6 +2085,9 @@
+ raise
+ if _runOnce:
+ logging.info( u"[Complete] %s" % time.asctime() )
++ try: codecs.open(os.path.join(getConfig()['global']['workingDir'],
++ getConfig()['global']['daemonInfo']), 'w', 'utf-8').write('')
++ except IOError, m: pass
+ break
+ logging.info( u"[Sleeping] %s" % time.asctime() )
+ checkSleep( getConfig()['global']['scanMins'] * 60 )