aboutsummaryrefslogtreecommitdiff
path: root/www/py-turbogears2
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-11 14:12:22 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-11 14:12:22 +0000
commit903460fc41ac79666ecc05f26d18cb060e078721 (patch)
tree1b8982af640e9bce702a63e99209c43812988a89 /www/py-turbogears2
parent3d23e404674e311e8118fbcac20e17248fd3c33f (diff)
downloadports-903460fc41ac79666ecc05f26d18cb060e078721.tar.gz
ports-903460fc41ac79666ecc05f26d18cb060e078721.zip
- Bumped PORTREVISION
- Removed option -D (ignored by the new version of easy_install), added -q to files/pkg-deinstall.in - Updated path to the Python egg of devel/py-kid (dependency), fixing build on pointyhat (reported by kris@) Approved by: alexbl (mentor, implicit)
Notes
Notes: svn path=/head/; revision=182099
Diffstat (limited to 'www/py-turbogears2')
-rw-r--r--www/py-turbogears2/Makefile5
-rw-r--r--www/py-turbogears2/files/pkg-deinstall.in2
2 files changed, 4 insertions, 3 deletions
diff --git a/www/py-turbogears2/Makefile b/www/py-turbogears2/Makefile
index 5ddeb4c851fc..c05539164957 100644
--- a/www/py-turbogears2/Makefile
+++ b/www/py-turbogears2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= TurboGears
PORTVERSION= 0.8.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www python
MASTER_SITES= http://nivi.interfree.it/distfiles/${PORTNAME}/ \
http://www.turbogears.org/download/eggs/
@@ -19,7 +19,7 @@ COMMENT= Python-Based Framework for Rapid Web Development
BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools \
- ${PYTHON_SITELIBDIR}/kid/__init__.py:${PORTSDIR}/devel/py-kid \
+ ${PYTHON_SITELIBDIR}/${PYKID_EGG}/kid/__init__.py:${PORTSDIR}/devel/py-kid \
sqlobject-admin:${PORTSDIR}/databases/py-sqlobject \
${PYTHON_SITELIBDIR}/cherrypy/__init__.py:${PORTSDIR}/www/py-cherrypy-old \
${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree \
@@ -57,5 +57,6 @@ RUN_DEPENDS+= cheetah:${PORTSDIR}/devel/py-cheetah
.endif
PYFORMENCODE_EGG!= ${MAKE} -f ${PORTSDIR}/www/py-formencode/Makefile -V PYFORMENCODE_EGG
+PYKID_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-kid/Makefile -V PYKID_EGG
.include <bsd.port.post.mk>
diff --git a/www/py-turbogears2/files/pkg-deinstall.in b/www/py-turbogears2/files/pkg-deinstall.in
index e184b62091c2..2d0f147f3ccf 100644
--- a/www/py-turbogears2/files/pkg-deinstall.in
+++ b/www/py-turbogears2/files/pkg-deinstall.in
@@ -5,7 +5,7 @@ PKGNAME=$1
case $2 in
DEINSTALL)
for f in %%EGGS%%
- do easy_install -x -m -D "%%PYTHON_SITELIBDIR%%/${f}"
+ do easy_install -q -x -m "%%PYTHON_SITELIBDIR%%/${f}"
done
;;
POST-DEINSTALL)