aboutsummaryrefslogtreecommitdiff
path: root/www/quickie
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-28 11:36:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-28 11:36:00 +0000
commite9cf5695a9722eb5f6f83df63fd52c5a3c557d3c (patch)
treea8d33850c43a6512bec1a1ba625dc2a6df80f120 /www/quickie
parent654d002861996b2a0d284bd28b2845c43de6888e (diff)
downloadports-e9cf5695a9722eb5f6f83df63fd52c5a3c557d3c.tar.gz
ports-e9cf5695a9722eb5f6f83df63fd52c5a3c557d3c.zip
- Fix some really brain-damaged build logic, to make port jobs-safe
- Tighten Makefile header and COMMENT line - Convert to OptionsNG and clean it up a bit while I am here Reported by: pointyhat-west
Notes
Notes: svn path=/head/; revision=323820
Diffstat (limited to 'www/quickie')
-rw-r--r--www/quickie/Makefile46
1 files changed, 24 insertions, 22 deletions
diff --git a/www/quickie/Makefile b/www/quickie/Makefile
index 38966fc7e8e1..348f527352dc 100644
--- a/www/quickie/Makefile
+++ b/www/quickie/Makefile
@@ -1,54 +1,54 @@
-# New ports collection makefile for: quickie
-# Date Created: 2006-05-16
-# Whom: Shaun Amott <shaun@inerd.com>
-#
+# Created by: Shaun Amott <shaun@inerd.com>
# $FreeBSD$
-#
PORTNAME= quickie
PORTVERSION= 1.1
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://${PORTNAME}.sourceforge.net/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+EXTRACT_ONLY:= ${DISTFILES}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A small footprint, fast Wiki engine written in C++
+COMMENT= Small footprint, fast Wiki engine written in C++
GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --sysconfdir=${PREFIX}/etc \
+CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}/etc \
--localstatedir=${DATADIR}
+USE_PERL5_BUILD= yes
+
+SUB_FILES= pkg-message
MAN1= quickie-config.1 quickie_prime.1 quickie.1 quickie_svt.1 \
quickie_license.1 quickie_post_install.1
+PORTDOCS= ${DISTNAME}.pdf
-SUB_FILES= pkg-message
+OPTIONS_DEFINE= CGI DOCS
+CGI_DESC= Install CGI binary
-PORTDOCS= ${DISTNAME}.pdf
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}.pdf
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.if ${PORT_OPTIONS:MDOCS}
+DISTFILES+= ${DISTNAME}.pdf
.endif
-.include <bsd.port.pre.mk>
-
post-patch:
@${CP} ${FILESDIR}/freebsd.h ${WRKSRC}/lib
@${REINPLACE_CMD} -e 's|output_html_quote::name()|name()|' \
${WRKSRC}/lib/output/html_quote.h
@${REINPLACE_CMD} -e 's|input_uudecode::read_inner|read_inner|' \
${WRKSRC}/lib/input/uudecode.h
+# Fix -jX builds: tell compiler to generate files in the right place
+ @${PERL} -0pi -e 's/(\$$\(CXX\).*?\s+-c\s+.*?) \
+ \s+mv\s+\S+/$$1 -o/sgx' ${WRKSRC}/Makefile.in
pre-install:
- @${MKDIR} ${DATADIR}/admin
- @${MKDIR} ${DATADIR}/manual
+ @${MKDIR} ${DATADIR}/admin ${DATADIR}/manual
post-install:
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${DATADIR}
-.if !defined(WITHOUT_CGICOPY)
- @if [ -d ${PREFIX}/www/cgi-bin/ ]; then \
+.if ${PORT_OPTIONS:MCGI}
+ @if [ -d ${PREFIX}/www/cgi-bin ]; then \
if [ ! -f ${PREFIX}/www/cgi-bin/${PORTNAME} ]; then \
${ECHO_MSG} "===> Copying CGI binary..." ; \
${CP} -p ${PREFIX}/bin/${PORTNAME} ${PREFIX}/www/cgi-bin/${PORTNAME} ; \
@@ -56,11 +56,13 @@ post-install:
fi ; \
fi
.endif
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DISTDIR}/${DISTNAME}.pdf ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>