aboutsummaryrefslogtreecommitdiff
path: root/www/rnews
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2010-08-25 08:03:43 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2010-08-25 08:03:43 +0000
commitf61179a5c288dca337ddf5f02f15798d3fa9a439 (patch)
tree78c512945232712c2ea9c3be86160c5682bf2e22 /www/rnews
parentc3f03316b9c1e53f304b5910fadea730c8699555 (diff)
downloadports-f61179a5c288dca337ddf5f02f15798d3fa9a439.tar.gz
ports-f61179a5c288dca337ddf5f02f15798d3fa9a439.zip
Update to 1.01.
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=259957
Diffstat (limited to 'www/rnews')
-rw-r--r--www/rnews/Makefile20
-rw-r--r--www/rnews/distinfo6
-rw-r--r--www/rnews/pkg-plist47
3 files changed, 59 insertions, 14 deletions
diff --git a/www/rnews/Makefile b/www/rnews/Makefile
index 7d313639b886..494712d5b43a 100644
--- a/www/rnews/Makefile
+++ b/www/rnews/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rnews
-PORTVERSION= 0.92
+PORTVERSION= 1.01
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -34,6 +34,8 @@ USE_PHP+= gd
RUN_DEPENDS+= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
.endif
+RUN_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+
.if !defined(NOPORTDOCS)
PORTDOCS= CHANGELOG INSTALL LICENSE README UPGRADE
.endif
@@ -44,18 +46,23 @@ do-install:
@${FIND} -s ${WRKSRC} -type d | ${SED} -e 's,^${WRKSRC},${WWWDIR},' \
| ${XARGS} ${MKDIR}
${INSTALL_DATA} -v ${WRKSRC}/*.php ${WWWDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.css ${WWWDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.js ${WWWDIR}
+ ${INSTALL_DATA} -v ${WRKSRC}/*.css ${WWWDIR}
+ ${INSTALL_DATA} -v ${WRKSRC}/*.js ${WWWDIR}
${INSTALL_DATA} ${WRKSRC}/.htaccess ${WWWDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tmp/.htaccess ${WWWDIR}/tmp
+ ${INSTALL_DATA} ${WRKSRC}/favicon.ico ${WWWDIR}
+ ${INSTALL_DATA} ${WRKSRC}/help.html ${WWWDIR}
${INSTALL_DATA} -v ${WRKSRC}/img/*.gif ${WWWDIR}/img
- ${INSTALL_DATA} ${WRKSRC}/img/*.png ${WWWDIR}/img
- ${INSTALL_DATA} ${WRKSRC}/img/*.jpg ${WWWDIR}/img
+ ${INSTALL_DATA} -v ${WRKSRC}/img/*.png ${WWWDIR}/img
+ ${INSTALL_DATA} -v ${WRKSRC}/img/*.jpg ${WWWDIR}/img
( ${FIND} ${WRKSRC}/inc -type f -not -name config_user.php -a -not -name config.php; ${ECHO} ${WWWDIR}/inc ) \
| ${XARGS} ${INSTALL_DATA} -v
${INSTALL_DATA} -v ${WRKSRC}/magpierss/*.inc ${WWWDIR}/magpierss
${INSTALL_DATA} ${WRKSRC}/magpierss/extlib/Snoopy.class.inc ${WWWDIR}/magpierss/extlib
+ ${INSTALL_DATA} -v ${WRKSRC}/opml/*.opml ${WWWDIR}/opml
@${CHOWN} ${WWWOWN} ${WWWDIR}/magpierss/cache
@${CHOWN} ${WWWOWN} ${WWWDIR}/img/feeds
+ @${CHOWN} ${WWWOWN} ${WWWDIR}/tmp
.for FILE in ${CONFIGS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${WWWDIR}/${FILE}.sample
.endfor
@@ -78,7 +85,8 @@ post-install:
create-plist:
@${FIND} -s ${WRKSRC} \( -name "*.php" -o -name "*.inc" -o -name "*.js" -o -name "*.css" -o -name "*.jpg" \
- -o -name "*.gif" -o -name "*.png" -o -name ".htaccess" \) -and -not -name config_user.php \
+ -o -name "*.gif" -o -name "*.png" -o -name ".htaccess" -o -name "help.html" -o -name "favicon.ico" -o -name "*.opml" \) \
+ -and -not -name config_user.php -and -not -name config.php \
| ${SED} -e 's,^${WRKSRC},%%WWWDIR%%,' > ${PLIST}
.for FILE in ${CONFIGS}
@${ECHO_CMD} '@exec if [ ! -f %D/%%WWWDIR%%/${FILE} ]; then \
diff --git a/www/rnews/distinfo b/www/rnews/distinfo
index 674db48a5f83..8d969f4d006e 100644
--- a/www/rnews/distinfo
+++ b/www/rnews/distinfo
@@ -1,3 +1,3 @@
-MD5 (rnews-0.92.tar.gz) = c084b033e82593744642baa682cc435e
-SHA256 (rnews-0.92.tar.gz) = 2518245736604414b75abf4f9a09e8ac1eaaa649d0185e681b04563008b092c0
-SIZE (rnews-0.92.tar.gz) = 135874
+MD5 (rnews-1.01.tar.gz) = afa4c64e341b8e756844767ac8ddb401
+SHA256 (rnews-1.01.tar.gz) = ccf838d46ab2143c8e5d5106e9a98279e95be111e57969e4555ae299645f0972
+SIZE (rnews-1.01.tar.gz) = 168782
diff --git a/www/rnews/pkg-plist b/www/rnews/pkg-plist
index 8b9b0824493a..2043184e4d24 100644
--- a/www/rnews/pkg-plist
+++ b/www/rnews/pkg-plist
@@ -3,11 +3,15 @@
%%WWWDIR%%/add_user.php
%%WWWDIR%%/ajax.js
%%WWWDIR%%/ajax.php
+%%WWWDIR%%/all.js
%%WWWDIR%%/auth.php
%%WWWDIR%%/book.php
+%%WWWDIR%%/cron.php
%%WWWDIR%%/export.php
+%%WWWDIR%%/favicon.ico
%%WWWDIR%%/foot.php
%%WWWDIR%%/functions.js
+%%WWWDIR%%/help.html
%%WWWDIR%%/img/b1-add_hv.png
%%WWWDIR%%/img/b1-add_nm.png
%%WWWDIR%%/img/b1-block.png
@@ -16,6 +20,12 @@
%%WWWDIR%%/img/b1-blockw.png
%%WWWDIR%%/img/b1-blockw_hv.png
%%WWWDIR%%/img/b1-blockw_nm.png
+%%WWWDIR%%/img/b1-filt-all.png
+%%WWWDIR%%/img/b1-filt-all_hv.png
+%%WWWDIR%%/img/b1-filt-all_nm.png
+%%WWWDIR%%/img/b1-filt-new.png
+%%WWWDIR%%/img/b1-filt-new_hv.png
+%%WWWDIR%%/img/b1-filt-new_nm.png
%%WWWDIR%%/img/b1-list.png
%%WWWDIR%%/img/b1-list_hv.png
%%WWWDIR%%/img/b1-list_nm.png
@@ -37,22 +47,40 @@
%%WWWDIR%%/img/b2-x_nm.png
%%WWWDIR%%/img/feedhdbg.png
%%WWWDIR%%/img/hdrbg.png
+%%WWWDIR%%/img/ib-bg.png
+%%WWWDIR%%/img/ib-delete_hv.png
+%%WWWDIR%%/img/ib-delete_nm.png
+%%WWWDIR%%/img/ib-fontbg_hv.png
+%%WWWDIR%%/img/ib-fontbg_nm.png
+%%WWWDIR%%/img/ib-fontsm_hv.png
+%%WWWDIR%%/img/ib-fontsm_nm.png
+%%WWWDIR%%/img/ib-link_hv.png
+%%WWWDIR%%/img/ib-link_nm.png
+%%WWWDIR%%/img/ib-mark_hv.png
+%%WWWDIR%%/img/ib-mark_nm.png
+%%WWWDIR%%/img/ib-marked_hv.png
+%%WWWDIR%%/img/ib-marked_nm.png
+%%WWWDIR%%/img/ib-markold_hv.png
+%%WWWDIR%%/img/ib-markold_nm.png
+%%WWWDIR%%/img/ib-star_hv.png
+%%WWWDIR%%/img/ib-star_nm.png
+%%WWWDIR%%/img/ib-unstar_hv.png
+%%WWWDIR%%/img/ib-unstar_nm.png
%%WWWDIR%%/img/loading.gif
-%%WWWDIR%%/img/more-seen.png
-%%WWWDIR%%/img/more.png
+%%WWWDIR%%/img/more_hv.png
+%%WWWDIR%%/img/more_nm.png
%%WWWDIR%%/img/morew_hv.png
%%WWWDIR%%/img/morew_nm.png
%%WWWDIR%%/img/rnews-logo.png
-%%WWWDIR%%/img/screenshot-0.90-sm-g.jpg
+%%WWWDIR%%/img/screenshot-sm-g.jpg
%%WWWDIR%%/img/xml.png
%%WWWDIR%%/inc/.htaccess
%%WWWDIR%%/inc/cl_cat.php
-%%WWWDIR%%/inc/cl_config.php
+%%WWWDIR%%/inc/cl_configw.php
%%WWWDIR%%/inc/cl_db.php
%%WWWDIR%%/inc/cl_feed.php
%%WWWDIR%%/inc/cl_feedlink.php
%%WWWDIR%%/inc/cl_user.php
-%%WWWDIR%%/inc/config.php
%%WWWDIR%%/inc/functions.php
%%WWWDIR%%/inc/kses.php
%%WWWDIR%%/inc/opml.php
@@ -67,12 +95,19 @@
%%WWWDIR%%/magpierss/rss_fetch.inc
%%WWWDIR%%/magpierss/rss_parse.inc
%%WWWDIR%%/magpierss/rss_utils.inc
+%%WWWDIR%%/opml/amusement.opml
+%%WWWDIR%%/opml/deals.opml
+%%WWWDIR%%/opml/language.opml
+%%WWWDIR%%/opml/news.opml
+%%WWWDIR%%/opml/photos.opml
+%%WWWDIR%%/opml/tech.opml
%%WWWDIR%%/prefs.php
%%WWWDIR%%/redirect.php
%%WWWDIR%%/rnews-ie6.css
%%WWWDIR%%/rnews-side.css
%%WWWDIR%%/rollover.js
%%WWWDIR%%/search.php
+%%WWWDIR%%/tmp/.htaccess
@exec if [ ! -f %D/%%WWWDIR%%/inc/config.php ]; then install -o root -g wheel -m 444 %D/%%WWWDIR%%/inc/config.php.sample %D/%%WWWDIR%%/inc/config.php; /usr/sbin/chown www %D/%%WWWDIR%%/inc/config.php; /bin/chmod u+w %D/%%WWWDIR%%/inc/config.php; fi
@exec if [ ! -f %D/%%WWWDIR%%/inc/config_user.php ]; then install -o root -g wheel -m 444 %D/%%WWWDIR%%/inc/config_user.php.sample %D/%%WWWDIR%%/inc/config_user.php; /usr/sbin/chown www %D/%%WWWDIR%%/inc/config_user.php; /bin/chmod u+w %D/%%WWWDIR%%/inc/config_user.php; fi
@unexec if cmp -s %D/%%WWWDIR%%/inc/config.php.sample %D/%%WWWDIR%%/inc/config.php; then /bin/rm -f %D/%%WWWDIR%%/inc/config.php; fi
@@ -85,4 +120,6 @@
@dirrm %%WWWDIR%%/magpierss/cache
@dirrm %%WWWDIR%%/magpierss/extlib
@dirrm %%WWWDIR%%/magpierss
+@dirrm %%WWWDIR%%/opml
+@dirrm %%WWWDIR%%/tmp
@dirrm %%WWWDIR%%