aboutsummaryrefslogtreecommitdiff
path: root/www/rt40
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-01-19 14:34:39 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-01-19 14:34:39 +0000
commit4165d5a02aec52597c695effdb00d9878e62134c (patch)
tree2a865d09b005fcfe70c6e9104e88cfbcd9df982f /www/rt40
parente0b088ff61a7491198441b8a6e4dd8bd2f4b730b (diff)
downloadports-4165d5a02aec52597c695effdb00d9878e62134c.tar.gz
ports-4165d5a02aec52597c695effdb00d9878e62134c.zip
* Since BUILD_DEPENDS is always going to be a super-set of
RUN_DEPENDS, simplfy things by calculating RUN_DEPENDS based on the OPTIONS settings, then just append that to BUILD_DEPENDS. No functional change to the generated packaage, so no PORTREVISION bump.
Notes
Notes: svn path=/head/; revision=340312
Diffstat (limited to 'www/rt40')
-rw-r--r--www/rt40/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index 5e71a49ffa1c..1fb4e7f59695 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -43,11 +43,11 @@ OPTIONS_DEFAULT= AP_MODPERL GD GPG MYSQL
USERS?= www
GROUPS?= rt www
-BUILD_DEPENDS+= ${LOCALBASE}/bin/jsmin:${PORTSDIR}/devel/jsmin
+RUN_DEPENDS+= ${LOCALBASE}/bin/jsmin:${PORTSDIR}/devel/jsmin
.include "${.CURDIR}/Makefile.cpan"
-BUILD_DEPENDS+= ${CORE_DEPS} \
+RUN_DEPENDS+= ${CORE_DEPS} \
${MASON_DEPS} \
${PSGI_DEPS} \
${MAILGATE_DEPS} \
@@ -58,8 +58,6 @@ BUILD_DEPENDS+= ${CORE_DEPS} \
${USERLOGO_DEPS} \
${HTML_DOC_DEPS}
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
USES+= perl5
USE_AUTOTOOLS= autoconf
@@ -69,64 +67,53 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
AP_MODPERL_DESC= Deploy with apache and mod_perl
-AP_MODPERL_BUILD_DEPENDS= ${MODPERL2_DEPS}
AP_MODPERL_RUN_DEPENDS= ${MODPERL2_DEPS}
AP_MODPERL_CONFIGURE_ON= --with-apachectl=${LOCALBASE}/sbin/apachectl
AP_MODFASTCGI_DESC= Deploy with apache and mod_fastcgi
AP_MODFASTCGI_USE= APACHE_RUN=22+
-AP_MODFASTCGI_BUILD_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
AP_MODFASTCGI_RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
${FASTCGI_DEPS}
AP_MODFASTCGI_CONFIGURE_ON= --with-apachectl=${LOCALBASE}/sbin/apachectl
LIGHTTPD_DESC= Deploy with lighttpd and mod_fastcgi
-LIGHTTPD_BUILD_DEPENDS= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
LIGHTTPD_RUN_DEPENDS= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
SPAWN_FCGI_DESC= Deploy with spawn_fcgi
-SPAWN_FCGI_BUILD_DEPENDS= ${LOCALBASE}/bin/spawn-fcgi:${PORTSDIR}/www/spawn-fcgi
SPAWN_FCGI_RUN_DEPENDS= ${LOCALBASE}/bin/spawn-fcgi:${PORTSDIR}/www/spawn-fcgi
MYSQL_USE= MYSQL=yes
-MYSQL_BUILD_DEPENDS= ${MYSQL_DEPS}
MYSQL_RUN_DEPENDS= ${MYSQL_DEPS}
PGSQL_USE= PGSQL=yes
-PGSQL_BUILD_DEPENDS= ${PGSQL_DEPS}
PGSQL_RUN_DEPENDS= ${PGSQL_DEPS}
-ORACLE_BUILD_DEPENDS= ${ORACLE_DEPS}
ORACLE_RUN_DEPENDS= ${ORACLE_DEPS}
SQLITE_USE= SQLITE=yes
-SQLITE_BUILD_DEPENDS= ${SQLITE_DEPS}
SQLITE_RUN_DEPENDS= ${SQLITE_DEPS}
DEV_DESC= Configure for Developers
-DEV_BUILD_DEPENDS= ${DEV_DEPS}
DEV_RUN_DEPENDS= ${DEV_DEPS}
DEV_CONFIGURE_ON= --enable-developer-mode
SSL_MAILGATE_DESC= Enable HTTPS support for rt-mailgate
-SSL_MAILGATE_BUILD_DEPENDS= ${SSL_MAILGATE_DEPS}
SSL_MAILGATE_RUN_DEPENDS= ${SSL_MAILGATE_DEPS}
SSL_MAILGATE_CONFIGURE_ENABLE= ssl-mailgate
-GRAPHVIZ_BUILD_DEPENDS= ${GRAPHVIZ_DEPS}
GRAPHVIZ_RUN_DEPENDS= ${GRAPHVIZ_DEPS}
GRAPHVIZ_CONFIGURE_ENABLE= graphviz
GPG_DESC= Enable GnuPG support
-GPG_BUILD_DEPENDS= ${GPG_DEPS}
GPG_RUN_DEPENDS= ${GPG_DEPS}
GPG_CONFIGURE_ENABLE= gpg
GD_DESC= Enable GD Graphs and Charts
-GD_BUILD_DEPENDS= ${GD_DEPS}
GD_RUN_DEPENDS= ${GD_DEPS}
GD_CONFIGURE_ENABLE= gd
+BUILD_DEPENDS+= ${RUN_DEPENDS}
+
.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MMYSQL} && !${PORT_OPTIONS:MPGSQL} && \