aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-hpricot
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-02-03 17:27:47 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-02-03 17:27:47 +0000
commit14a9092497ecedca5b965e18ee57aa5c167dbd14 (patch)
treeeb66dc666258e783bd0b8736e84b2371314bc197 /www/rubygem-hpricot
parentea5d544a350466c2a1334571354b266db54ef9f0 (diff)
downloadports-14a9092497ecedca5b965e18ee57aa5c167dbd14.tar.gz
ports-14a9092497ecedca5b965e18ee57aa5c167dbd14.zip
Hpricot is a very flexible HTML parser, based on Tanaka Akira's HTree
and John Resig's JQuery, but with the scanner recoded in C (using Ragel for scanning.) WWW: http://code.whytheluckystiff.net/hpricot/
Notes
Notes: svn path=/head/; revision=184044
Diffstat (limited to 'www/rubygem-hpricot')
-rw-r--r--www/rubygem-hpricot/Makefile18
-rw-r--r--www/rubygem-hpricot/distinfo3
-rw-r--r--www/rubygem-hpricot/pkg-descr5
-rw-r--r--www/rubygem-hpricot/pkg-plist41
4 files changed, 67 insertions, 0 deletions
diff --git a/www/rubygem-hpricot/Makefile b/www/rubygem-hpricot/Makefile
new file mode 100644
index 000000000000..a2e6deae1dcd
--- /dev/null
+++ b/www/rubygem-hpricot/Makefile
@@ -0,0 +1,18 @@
+# Ports collection makefile for: rubygem-hpricot
+# Date created: Jan 19, 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= hpricot
+PORTVERSION= 0.4
+CATEGORIES= www rubygems
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= gems
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A Fast, Enjoyable HTML Parser for Ruby
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-hpricot/distinfo b/www/rubygem-hpricot/distinfo
new file mode 100644
index 000000000000..9f46faaff7de
--- /dev/null
+++ b/www/rubygem-hpricot/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/hpricot-0.4.gem) = cc631d6612b625a825bab2cd2de6251f
+SHA256 (rubygem/hpricot-0.4.gem) = f51675978aa0660d57593219286a0c1f81cf6b10e21cda94c867d8c741938b0e
+SIZE (rubygem/hpricot-0.4.gem) = 126464
diff --git a/www/rubygem-hpricot/pkg-descr b/www/rubygem-hpricot/pkg-descr
new file mode 100644
index 000000000000..c8445555f4f6
--- /dev/null
+++ b/www/rubygem-hpricot/pkg-descr
@@ -0,0 +1,5 @@
+Hpricot is a very flexible HTML parser, based on Tanaka Akira's HTree
+and John Resig's JQuery, but with the scanner recoded in
+C (using Ragel for scanning.)
+
+WWW: http://code.whytheluckystiff.net/hpricot/
diff --git a/www/rubygem-hpricot/pkg-plist b/www/rubygem-hpricot/pkg-plist
new file mode 100644
index 000000000000..c88f7fd67b58
--- /dev/null
+++ b/www/rubygem-hpricot/pkg-plist
@@ -0,0 +1,41 @@
+%%GEM_CACHE%%
+%%GEM_LIB_DIR%%/CHANGELOG
+%%GEM_LIB_DIR%%/COPYING
+%%GEM_LIB_DIR%%/README
+%%GEM_LIB_DIR%%/Rakefile
+%%GEM_LIB_DIR%%/ext/hpricot_scan/Makefile
+%%GEM_LIB_DIR%%/ext/hpricot_scan/extconf.rb
+%%GEM_LIB_DIR%%/ext/hpricot_scan/hpricot_scan.c
+%%GEM_LIB_DIR%%/ext/hpricot_scan/hpricot_scan.h
+%%GEM_LIB_DIR%%/ext/hpricot_scan/hpricot_scan.o
+%%GEM_LIB_DIR%%/ext/hpricot_scan/hpricot_scan.rl
+%%GEM_LIB_DIR%%/ext/hpricot_scan/hpricot_scan.so
+%%GEM_LIB_DIR%%/ext/hpricot_scan/mkmf.log
+%%GEM_LIB_DIR%%/extras/mingw-rbconfig.rb
+%%GEM_LIB_DIR%%/lib/hpricot.rb
+%%GEM_LIB_DIR%%/lib/hpricot/elements.rb
+%%GEM_LIB_DIR%%/lib/hpricot/htmlinfo.rb
+%%GEM_LIB_DIR%%/lib/hpricot/inspect.rb
+%%GEM_LIB_DIR%%/lib/hpricot/modules.rb
+%%GEM_LIB_DIR%%/lib/hpricot/parse.rb
+%%GEM_LIB_DIR%%/lib/hpricot/tag.rb
+%%GEM_LIB_DIR%%/lib/hpricot/text.rb
+%%GEM_LIB_DIR%%/lib/hpricot/traverse.rb
+%%GEM_LIB_DIR%%/lib/hpricot_scan.so
+%%GEM_LIB_DIR%%/test/files/basic.xhtml
+%%GEM_LIB_DIR%%/test/files/boingboing.html
+%%GEM_LIB_DIR%%/test/files/immob.html
+%%GEM_LIB_DIR%%/test/files/uswebgen.html
+%%GEM_LIB_DIR%%/test/load_files.rb
+%%GEM_LIB_DIR%%/test/test_parser.rb
+%%GEM_SPEC%%
+@dirrm %%GEM_LIB_DIR%%/test/files
+@dirrm %%GEM_LIB_DIR%%/test
+@dirrm %%GEM_LIB_DIR%%/extras
+@dirrm %%GEM_LIB_DIR%%/ext/hpricot_scan
+@dirrm %%GEM_LIB_DIR%%/ext
+@dirrm %%GEM_LIB_DIR%%/lib/hpricot
+@dirrm %%GEM_LIB_DIR%%/lib
+@dirrm %%GEM_LIB_DIR%%/bin
+@dirrm %%GEM_LIB_DIR%%
+@dirrm %%GEM_DOC_DIR%%