aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-typhoeus
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-10-02 17:23:55 +0000
committerSteve Wills <swills@FreeBSD.org>2011-10-02 17:23:55 +0000
commit76d05ae68a581dd333390a85fbc33740e1712731 (patch)
treec70b47e316dd8d0ab3267dd7d995c9cef391465f /www/rubygem-typhoeus
parentfb3a2d1c705a5bbc400f0c0a877b0e7d14eb9b84 (diff)
downloadports-76d05ae68a581dd333390a85fbc33740e1712731.tar.gz
ports-76d05ae68a581dd333390a85fbc33740e1712731.zip
Typhoeus runs HTTP requests in parallel while
cleanly encapsulating handling logic. It's a library for accessing web services in Ruby, specifically designed for building RESTful service oriented architectures in Ruby that need to be fast enough to process calls to multiple services within the client's HTTP request/response life cycle. WWW: https://github.com/dbalatero/typhoeus PR: ports/158313 Submitted by: Eric Freeman <freebsdports@chillibear.com>
Notes
Notes: svn path=/head/; revision=282809
Diffstat (limited to 'www/rubygem-typhoeus')
-rw-r--r--www/rubygem-typhoeus/Makefile23
-rw-r--r--www/rubygem-typhoeus/distinfo2
-rw-r--r--www/rubygem-typhoeus/pkg-descr10
3 files changed, 35 insertions, 0 deletions
diff --git a/www/rubygem-typhoeus/Makefile b/www/rubygem-typhoeus/Makefile
new file mode 100644
index 000000000000..91f1b1f01b1b
--- /dev/null
+++ b/www/rubygem-typhoeus/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: rubygem-typhoeus
+# Date created: 26 June 2011
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= typhoeus
+PORTVERSION= 0.2.4
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Parallel HTTP request library
+
+RUN_DEPENDS= rubygem-mime-types>=0:${PORTSDIR}/misc/rubygem-mime-types
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-typhoeus/distinfo b/www/rubygem-typhoeus/distinfo
new file mode 100644
index 000000000000..2c81842a2a2a
--- /dev/null
+++ b/www/rubygem-typhoeus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/typhoeus-0.2.4.gem) = f8127150288eeb484391710ea415dce1fb9555d5deca41f58b6009771ae3f0fc
+SIZE (rubygem/typhoeus-0.2.4.gem) = 49664
diff --git a/www/rubygem-typhoeus/pkg-descr b/www/rubygem-typhoeus/pkg-descr
new file mode 100644
index 000000000000..0a8b79911e07
--- /dev/null
+++ b/www/rubygem-typhoeus/pkg-descr
@@ -0,0 +1,10 @@
+Typhoeus runs HTTP requests in parallel while
+cleanly encapsulating handling logic.
+
+It's a library for accessing web services in Ruby,
+specifically designed for building RESTful service
+oriented architectures in Ruby that need to be fast
+enough to process calls to multiple services within
+the client's HTTP request/response life cycle.
+
+WWW: https://github.com/dbalatero/typhoeus