aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-22 10:37:32 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-22 10:37:32 +0000
commit18b34ab43029adb1b9e31603f699cd65d69c7bea (patch)
treec03ca2fc999952d2492579be585828404b7f1526 /www/seamonkey
parent4a6d68a30e8c1e69ecc372b7a6496b423a939def (diff)
downloadports-18b34ab43029adb1b9e31603f699cd65d69c7bea.tar.gz
ports-18b34ab43029adb1b9e31603f699cd65d69c7bea.zip
Correct empty directories pruning code.
Notes
Notes: svn path=/head/; revision=42901
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 142c2f384861..ed7681c24c1e 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -67,9 +67,7 @@ post-build:
${ECHO} skin,install,select,classic/1.0 >> chrome/installed-chrome.txt; \
${ECHO} locale,install,select,en-US >> chrome/installed-chrome.txt; \
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
- # Prune empty chrome dirs, so we don't have to pollute PLIST with
- # zillion "@exec mkdir" and "@dirrm"
- @/usr/bin/find ${WRKSRC}/dist/bin -type d | \
+ @/usr/bin/find ${WRKSRC}/dist/bin -type d | /usr/bin/sort -r | \
/usr/bin/xargs ${RMDIR} 2> /dev/null || ${TRUE}
do-install: