aboutsummaryrefslogtreecommitdiff
path: root/www/shttpd
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-12-20 18:16:48 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-12-20 18:16:48 +0000
commit050d68362ba9248e5319605f7c1498f6724a3da2 (patch)
tree0b438cd9c05c8a9a93f19f245cadbd7a14fd24ea /www/shttpd
parent5f15dbc5186e933633166ce131192f2e20bd791d (diff)
downloadports-050d68362ba9248e5319605f7c1498f6724a3da2.tar.gz
ports-050d68362ba9248e5319605f7c1498f6724a3da2.zip
- Update to 1.3
PR: ports/75227 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=124611
Diffstat (limited to 'www/shttpd')
-rw-r--r--www/shttpd/Makefile14
-rw-r--r--www/shttpd/distinfo4
-rw-r--r--www/shttpd/files/shttpd.19
3 files changed, 21 insertions, 6 deletions
diff --git a/www/shttpd/Makefile b/www/shttpd/Makefile
index 5399a57039f9..888c63d1ce70 100644
--- a/www/shttpd/Makefile
+++ b/www/shttpd/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= shttpd
-PORTVERSION= 1.0
+PORTVERSION= 1.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= shttpd
-DISTNAME= httpd.c
+DISTNAME= shttpd_${PORTVERSION}.c
EXTRACT_SUFX=
EXTRACT_ONLY= #none
@@ -21,13 +21,19 @@ NO_WRKSUBDIR= yes
DIST_SUBDIR= ${PORTNAME}
MAN1= shttpd.1
+.if defined(WITHOUT_SSL)
+PKGNAMESUFFIX= -nossl
+.else
+CFLAGS+= -DWITH_SSL -I/usr/include/openssl -lssl -lcrypto
+.endif
+
PLIST_FILES= bin/shttpd
post-extract:
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/httpd.c ${WRKSRC}/
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}/
do-build:
- ${CC} ${CFLAGS} -o ${WRKSRC}/shttpd ${WRKSRC}/httpd.c
+ ${CC} ${CFLAGS} -o ${WRKSRC}/shttpd ${WRKSRC}/${DISTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/shttpd ${PREFIX}/bin
diff --git a/www/shttpd/distinfo b/www/shttpd/distinfo
index 388f7caec70f..ff6ef85aca96 100644
--- a/www/shttpd/distinfo
+++ b/www/shttpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (shttpd/httpd.c) = b889be47e050449250931c46ba40b525
-SIZE (shttpd/httpd.c) = 41033
+MD5 (shttpd/shttpd_1.3.c) = 87af500089250ff5186ee553311b856e
+SIZE (shttpd/shttpd_1.3.c) = 42037
diff --git a/www/shttpd/files/shttpd.1 b/www/shttpd/files/shttpd.1
index 2c2ced3a6c6e..c1bf8752e87a 100644
--- a/www/shttpd/files/shttpd.1
+++ b/www/shttpd/files/shttpd.1
@@ -20,6 +20,15 @@ listening port (default 80 for non-SSL, 443 for SSL mode)
.I \-h
display help
.TP 13
+.I \-S
+use SSL (default NO)
+.TP 13
+.I \-s certfile
+use SSL certificate file (default httpd.pem)
+.TP 13
+.I \-e errfile
+error log file (default none)
+.TP 13
.I \-l logfile
log file (default httpd.log)
.TP 13