aboutsummaryrefslogtreecommitdiff
path: root/www/shttpd
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-06-14 10:28:47 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-06-14 10:28:47 +0000
commit0c3d914dd8b6e15455d19c18c3e706b4a081f905 (patch)
tree08a27a730a845415a1deccd78c62af30d905773f /www/shttpd
parentad8fb0c4de237377126b68d8633aa9458d09a8c7 (diff)
downloadports-0c3d914dd8b6e15455d19c18c3e706b4a081f905.tar.gz
ports-0c3d914dd8b6e15455d19c18c3e706b4a081f905.zip
- Update to 1.24
- Change COMMENT and description PR: ports/82220 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=137425
Diffstat (limited to 'www/shttpd')
-rw-r--r--www/shttpd/Makefile21
-rw-r--r--www/shttpd/distinfo4
-rw-r--r--www/shttpd/files/shttpd.183
-rw-r--r--www/shttpd/pkg-descr15
4 files changed, 16 insertions, 107 deletions
diff --git a/www/shttpd/Makefile b/www/shttpd/Makefile
index c46c572aa7f0..0f1469cab6f0 100644
--- a/www/shttpd/Makefile
+++ b/www/shttpd/Makefile
@@ -6,19 +6,15 @@
#
PORTNAME= shttpd
-PORTVERSION= 1.19
+PORTVERSION= 1.24
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= shttpd
-DISTNAME= shttpd_${PORTVERSION}.c
-EXTRACT_SUFX=
-EXTRACT_ONLY= #none
+DISTNAME= shttpd-${PORTVERSION}
MAINTAINER= valenok@gmail.com
-COMMENT= Simple embeddable web server with CGI support
+COMMENT= Small, fast, embeddable web server with CGI, SSL, Authorization
-NO_WRKSUBDIR= yes
-DIST_SUBDIR= ${PORTNAME}
MAN1= shttpd.1
.if defined(WITHOUT_SSL)
@@ -27,16 +23,15 @@ PKGNAMESUFFIX= -nossl
CFLAGS+= -DWITH_SSL -lssl -lcrypto
.endif
-PLIST_FILES= bin/shttpd
-
-post-extract:
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}/
+PLIST_FILES= bin/shttpd etc/shttpd.conf
do-build:
- ${CC} ${CFLAGS} -o ${WRKSRC}/shttpd ${WRKSRC}/${DISTNAME}
+ ${CC} ${CFLAGS} -DCONFIG=\"${PREFIX}/etc/shttpd.conf\" \
+ ${WRKSRC}/shttpd.c -o ${WRKSRC}/shttpd
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/shttpd ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/shttpd.1 ${PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/shttpd.conf ${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/shttpd.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/www/shttpd/distinfo b/www/shttpd/distinfo
index f0a892a4cf8f..0b03109e9bca 100644
--- a/www/shttpd/distinfo
+++ b/www/shttpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (shttpd/shttpd_1.19.c) = c2467c0167f1c57f8204f5c056a4a039
-SIZE (shttpd/shttpd_1.19.c) = 82026
+MD5 (shttpd-1.24.tar.gz) = 9201c1bf832c5365b3593bc6e036a47e
+SIZE (shttpd-1.24.tar.gz) = 40696
diff --git a/www/shttpd/files/shttpd.1 b/www/shttpd/files/shttpd.1
deleted file mode 100644
index 7f5e6e0ac01a..000000000000
--- a/www/shttpd/files/shttpd.1
+++ /dev/null
@@ -1,83 +0,0 @@
-.TH SHTTPD 1
-.SH NAME
-shttpd \- Simple HTTP Daemon
-.SH SYNOPSIS
-.PP
-.B shttpd
-.I [OPTIONS]
-.PP
-.B http stream tcp nowait nobody /usr/local/bin/shttpd shttpd -I -d /var/www
-.SH "DESCRIPTION"
-.B shttpd
-is a simple web server. It supports: CGI, Digest authentication, cookies,
-GET, POST, PUT, DELETE methods, SSL. It does not detach from terminal.
-It stores logs in a standard format. If -d option is not given, the document
-root is assumed to be the current directory.
-.P
-.B shttpd
-can be embedded into existing application, in order to provide a Web GUI.
-To do that, a header file with interface definition is needed, and application
-should be compiled with shttpd.c, with -DEMBEDDED compilation flag set.
-Refer to http://shttpd.sf.net to get the header file.
-.P
-.B shttpd
-can be run as stand-alone server, or it may be managed by the
-.I inetd(8)
-superdaemon. In latter case,
-.I \-I
-option should be specified in inetd configuration line.
-.SH OPTIONS
-.TP 13
-.I \-d directory
-document root directory (default .)
-.TP 13
-.I \-p port
-listening port (default 80 for non-SSL, 443 for SSL mode)
-.TP 13
-.I \-h
-display help
-.TP 13
-.I \-S
-use SSL
-.TP 13
-.I \-s certfile
-use SSL certificate file (default shttpd.pem)
-.TP 13
-.I \-e errfile
-error log file (default none)
-.TP 13
-.I \-l logfile
-log file (default shttpd.log)
-.TP 13
-.I \-I
-inetd mode
-.TP 13
-.I \-i file1[,file2..]
-index file (default index.html,index.cgi)
-.TP 13
-.I \-c pattern
-CGI file pattern (default .cgi)
-.TP 13
-.I \-P passfile
-global auth passwords file (default none)
-.TP 13
-.I \-u username
-switch UID to given username's UID (default none)
-.TP 13
-.I \-m file
-mime types file (default none)
-.TP 13
-.I \-N realm
-authentication realm (default mydomain.com)
-.TP 13
-.I \-D
-forbid directory listing
-.SH FILES
-.I /etc/inetd.conf
-.SH SEE ALSO
-.I inetd(8)
-.SH COPYRIGHT
-.B shttpd
-is licensed under the terms of MIT license.
-.SH AUTHOR
-Sergey Lyubka <valenok@gmail.com>
diff --git a/www/shttpd/pkg-descr b/www/shttpd/pkg-descr
index b9693333432c..eb9a3b93ba90 100644
--- a/www/shttpd/pkg-descr
+++ b/www/shttpd/pkg-descr
@@ -1,10 +1,7 @@
-SHTTPD is a simple, easy to use, embeddable web server with CGI,
-SSL, cookies support. It is written in C, as one single source file httpd.c,
-and compiles both in UNIX and Windows environments. Gives exceptionally
-small footprint when linked against uclibc or dietlibc. It is a good choice
-to serve Web based GUI for various applications, where other sophisticated
-servers like Apache, IIS etc are too big, hard to install and configure or
-overcomplicated.
-shttpd is licensed under the terms of very liberal MIT license.
+SHTTPD is small, fast and easy to use web server. It supports CGI, SSL,
+Digest Authorization. The unique feature of SHTTPD is the ability to
+embed it into existing C/C++ applications. Embedded API is very clean
+and simple. SHTTPD has small memory footprint. Use it when other
+web servers like Apache are too heavy for your tasks.
-WWW: http://shttpd.sf.net
+WWW: http://shttpd.sourceforge.net