aboutsummaryrefslogtreecommitdiff
path: root/www/sidplug/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-01-09 15:12:11 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-01-09 15:12:11 +0000
commitaf567d5554bf83255a8383b882ed02823064ed32 (patch)
tree6276b546dcd9b74f9bcea966dd4e0da91c2eebda /www/sidplug/Makefile
parent07e7add5a7ca4f9a7b4d670273a58afc14a196d8 (diff)
downloadports-af567d5554bf83255a8383b882ed02823064ed32.tar.gz
ports-af567d5554bf83255a8383b882ed02823064ed32.zip
New port sidplug version 1.1.4: A Commodore 64 psid audio plugin
for Mozilla web browser PR: 32846 Submitted by: John Merryweather Cooper <jmcoopr@webmail.bmi.net>
Notes
Notes: svn path=/head/; revision=52819
Diffstat (limited to 'www/sidplug/Makefile')
-rw-r--r--www/sidplug/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/sidplug/Makefile b/www/sidplug/Makefile
new file mode 100644
index 000000000000..1bff84ab7e7c
--- /dev/null
+++ b/www/sidplug/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: sidplug
+# Date created: 14 December 2001
+# Whom: John Merryweather Cooper <jmcoopr@webmail.bmi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sidplug
+PORTVERSION= 1.1.4
+CATEGORIES= www audio
+MASTER_SITES= http://www.geocities.com/SiliconValley/Lakes/5147/sidplay/packages/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jmcoopr@webmail.bmi.net
+
+RUN_DEPENDS= xsidplay:${PORTSDIR}/audio/xsidplay \
+ mozilla:${PORTSDIR}/www/mozilla
+
+USE_X_PREFIX= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/mozilla/plugins
+ @${INSTALL_PROGRAM} ${WRKSRC}/npsidplug.so ${PREFIX}/lib/mozilla/plugins
+ @${LN} -sf ${X11BASE}/bin/xsidplay ${PREFIX}/bin/sidplug
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Lazy_Fast.sid ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.html ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sidplug.png ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>