aboutsummaryrefslogtreecommitdiff
path: root/www/smarty/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-09 20:29:35 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-09 20:29:35 +0000
commitc5ecded283a20a51f6b00179d451043500180dbc (patch)
treefba85fea20246e05acff8f0f7d6d53b2309f782d /www/smarty/Makefile
parentd3efda6ac08a3a89fa74bcc50d049c38b91b8196 (diff)
downloadports-c5ecded283a20a51f6b00179d451043500180dbc.tar.gz
ports-c5ecded283a20a51f6b00179d451043500180dbc.zip
Add smarty 2.0, the PHP compiling template engine.
PR: 35748 Submitted by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
Notes
Notes: svn path=/head/; revision=61000
Diffstat (limited to 'www/smarty/Makefile')
-rw-r--r--www/smarty/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
new file mode 100644
index 000000000000..47258cf132a6
--- /dev/null
+++ b/www/smarty/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: smarty
+# Date created: 10 March 2002
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smarty
+PORTVERSION= 2.0
+CATEGORIES= www
+MASTER_SITES= http://www.phpinsider.com/php/code/Smarty/download/
+DISTFILES= Smarty-${PORTVERSION}${EXTRACT_SUFX}
+.if !defined(NOPORTDOCS)
+DISTFILES+= Smarty-${PORTVERSION}-docs${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= corecode@corecode.ath.cx
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
+
+NO_BUILD= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+MSG_SRC=${FILESDIR}/pkg-message
+
+MSG_SUB= DATADIR=${DATADIR} LOCALBASE=${LOCALBASE}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php overlib.js
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
+.endfor
+ @${MKDIR} ${DATADIR}/plugins
+ @${INSTALL_DATA} ${WRKSRC}/plugins/* ${DATADIR}/plugins
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in BUGS FAQ INSTALL QUICKSTART README RESOURCES
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+ @${MKDIR} ${DOCSDIR}/manual
+ @${INSTALL_DATA} ${WRKDIR}/manual/* ${DOCSDIR}/manual
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/index.php ${EXAMPLESDIR}
+.for f in configs templates templates_c cache
+ @${MKDIR} ${EXAMPLESDIR}/$f
+ @-${INSTALL_DATA} ${WRKSRC}/$f/* ${EXAMPLESDIR}/$f 2>/dev/null || ${TRUE}
+.endfor
+.endif
+
+post-install:
+ @${SED} ${MSG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${MSG_SRC} > \
+ ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>