aboutsummaryrefslogtreecommitdiff
path: root/www/smarty/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-07-23 03:22:42 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-07-23 03:22:42 +0000
commitcdb8225a87ea46874c8280d761b44b21a02321fb (patch)
treec5ff7e2f227ffdf7a164e8a38b553cd1ae273700 /www/smarty/Makefile
parent9f38eb6da15692c39c27544a526e0c8091fd9659 (diff)
downloadports-cdb8225a87ea46874c8280d761b44b21a02321fb.tar.gz
ports-cdb8225a87ea46874c8280d761b44b21a02321fb.zip
PR: 54115
Submitted by: Gary Palmer <freebsd-gnats@in-addr.com> Reviewed by: Approved by: Obtained from: MFC after: Upgrade smarty to 2.5.0. maintainer response timeout ~= 2 weeks
Notes
Notes: svn path=/head/; revision=85408
Diffstat (limited to 'www/smarty/Makefile')
-rw-r--r--www/smarty/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
index 3b6a871a055f..555ac94d0407 100644
--- a/www/smarty/Makefile
+++ b/www/smarty/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= smarty
-PORTVERSION= 2.4.2
+PORTVERSION= 2.5.0
CATEGORIES= www
MASTER_SITES= http://smarty.php.net/distributions/ \
http://smarty.php.net/distributions/manual/en/:manual
DISTFILES= Smarty-${PORTVERSION}${EXTRACT_SUFX}
.if !defined(NOPORTDOCS)
-DISTFILES+= Smarty-2.4.0-docs${EXTRACT_SUFX}:manual
+DISTFILES+= Smarty-2.5.0-docs${EXTRACT_SUFX}:manual
.endif
MAINTAINER= zaa@ulstu.ru
@@ -34,22 +34,22 @@ CPIO?= /usr/bin/cpio
do-install:
@${MKDIR} ${DATADIR}
.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
- @${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/libs/$f ${DATADIR}
.endfor
@${MKDIR} ${DATADIR}/plugins
- @${INSTALL_DATA} ${WRKSRC}/plugins/* ${DATADIR}/plugins
+ @${INSTALL_DATA} ${WRKSRC}/libs/plugins/* ${DATADIR}/plugins
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in BUGS FAQ INSTALL NEWS QUICKSTART README RESOURCES
+.for f in BUGS FAQ INSTALL NEWS README
@${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
.endfor
@${MKDIR} ${DOCSDIR}/manual
@cd ${WRKDIR}/manual && ${FIND} . | ${CPIO} --quiet -dumpR ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/manual
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/index.php ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/demo/index.php ${EXAMPLESDIR}
.for f in configs templates templates_c cache
@${MKDIR} ${EXAMPLESDIR}/$f
- @-${INSTALL_DATA} ${WRKSRC}/$f/* ${EXAMPLESDIR}/$f 2>/dev/null || ${TRUE}
+ @-${INSTALL_DATA} ${WRKSRC}/demo/$f/* ${EXAMPLESDIR}/$f 2>/dev/null || ${TRUE}
.endfor
.endif