aboutsummaryrefslogtreecommitdiff
path: root/www/spreadlogd/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-14 11:12:15 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-14 11:12:15 +0000
commit0ceee22139cdaca93835fd0a1d7c6eb775df0194 (patch)
treed80788c5893cfb22e9592b9355ed07bc508a9fa0 /www/spreadlogd/Makefile
parent93eac884d93e57c151c8a6b63c9a5a06f0bfb442 (diff)
downloadports-0ceee22139cdaca93835fd0a1d7c6eb775df0194.tar.gz
ports-0ceee22139cdaca93835fd0a1d7c6eb775df0194.zip
Add spreadlogd.
If you kill -HUP or kill the spreadlogd process, it will not actually process the signal until after it has received its next message from Spread. You can move you log files to new names and then kill -HUP and it will reopen the log files. This is useful for seamless log rotation without losing any messages. Spread is really cool. It is a poweful group communication toolkit developed at the Center for Networking and Distributed Systems at the Johns Hopkins University (http://www.spread.org/ and http://www.cnds.jhu.edu/, respectively). WWW: http://www.lethargy.org/mod_log_spread/ PR: ports/80877 Submitted by: Meno Abels <meno.abels@adviser.com>
Notes
Notes: svn path=/head/; revision=135227
Diffstat (limited to 'www/spreadlogd/Makefile')
-rw-r--r--www/spreadlogd/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/www/spreadlogd/Makefile b/www/spreadlogd/Makefile
new file mode 100644
index 000000000000..40a73f833e62
--- /dev/null
+++ b/www/spreadlogd/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: spreadlogd
+# Date created: 08 May 2005
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spreadlogd
+PORTVERSION= 1.4.2
+CATEGORIES= www net
+MASTER_SITES= http://www.lethargy.org/mod_log_spread/
+
+MAINTAINER= meno.abels@adviser.com
+COMMENT= The backend of mod_log_spread
+
+LIB_DEPENDS= spread.1:${PORTSDIR}/net/spread
+
+MAKEFILE= makefile
+USE_REINPLACE= yes
+
+USE_RC_SUBR= spreadlogd.sh
+SUB_FILES= spreadlogd.sh
+
+PLIST_FILES= sbin/spreadlogd etc/spreadlogd.conf.sample
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README Artistic.txt
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/spreadlogd.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/spreadlogd ${PREFIX}/sbin
+ ${INSTALL} ${WRKSRC}/spreadlogd.conf ${PREFIX}/etc/spreadlogd.conf.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>