aboutsummaryrefslogtreecommitdiff
path: root/www/squid31
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-29 23:15:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-29 23:15:51 +0000
commitd740d58409bb3a60ce9aebc3694025c28a80cdaa (patch)
treec9e9e64ce193d94ec9341b5edbbfb7736e91ab3d /www/squid31
parentd3dab474bfc5a1fdb53cd993552cf0396e3de82c (diff)
downloadports-d740d58409bb3a60ce9aebc3694025c28a80cdaa.tar.gz
ports-d740d58409bb3a60ce9aebc3694025c28a80cdaa.zip
- Include a (temporary) vendor patch for Squid bug #2206
("no proxy-Authenticate header in 407 response") from Squid bugzilla - Correct the patch for Squid bug #2203 to use the fix prefered by the Squid developers (see this bug's bugzilla entry) - Bump PORTREVISION PR: 122133 Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer)
Notes
Notes: svn path=/head/; revision=210101
Diffstat (limited to 'www/squid31')
-rw-r--r--www/squid31/Makefile1
-rw-r--r--www/squid31/files/patch-bug-220650
-rw-r--r--www/squid31/files/patch-configure32
3 files changed, 66 insertions, 17 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index b8cf265d694f..460581cfa390 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -63,6 +63,7 @@
PORTNAME= squid
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
diff --git a/www/squid31/files/patch-bug-2206 b/www/squid31/files/patch-bug-2206
new file mode 100644
index 000000000000..c6ab20f58013
--- /dev/null
+++ b/www/squid31/files/patch-bug-2206
@@ -0,0 +1,50 @@
+Temporary patch for Squid bug 2206 ("no proxy Authenticate header in 407
+response") as fetched from Squid bugzilla 2008-03-26.
+
+See <http://www.squid-cache.org/bugs/show_bug_cgi?id=2206> for further
+information.
+=== modified file 'src/HttpHeader.cc'
+--- src/HttpHeader.cc 2008-02-27 12:59:29 +0000
++++ src/HttpHeader.cc 2008-03-12 20:53:15 +0000
+@@ -1806,5 +1806,7 @@
+ }
+ if (headers_deleted)
+ refreshMask();
++
++ delById(HDR_CONNECTION);
+ }
+ }
+
+=== modified file 'src/HttpHeader.h'
+--- src/HttpHeader.h 2008-02-27 12:59:29 +0000
++++ src/HttpHeader.h 2008-03-12 20:53:56 +0000
+@@ -247,15 +247,13 @@
+ int hasListMember(http_hdr_type id, const char *member, const char separator) const;
+ int hasByNameListMember(const char *name, const char *member, const char separator) const;
+ void removeHopByHopEntries();
++ void removeConnectionHeaderEntries();
+ /* protected, do not use these, use interface functions instead */
+ Vector<HttpHeaderEntry *> entries; /* parsed fields in raw format */
+ HttpHeaderMask mask; /* bit set <=> entry present */
+ http_hdr_owner_type owner; /* request or reply */
+ int len; /* length when packed, not counting terminating '\0' */
+
+-protected:
+- void removeConnectionHeaderEntries();
+-
+ private:
+ HttpHeaderEntry *findLastEntry(http_hdr_type id) const;
+ // Make it non-copyable. Our destructor is a bit nasty...
+
+=== modified file 'src/client_side_reply.cc'
+--- src/client_side_reply.cc 2008-02-27 12:59:29 +0000
++++ src/client_side_reply.cc 2008-03-12 20:54:37 +0000
+@@ -1214,7 +1214,7 @@
+ if (is_hit)
+ hdr->delById(HDR_SET_COOKIE);
+
+- reply->header.removeHopByHopEntries();
++ reply->header.removeConnectionHeaderEntries();
+
+ // if (request->range)
+ // clientBuildRangeHeader(http, reply);
diff --git a/www/squid31/files/patch-configure b/www/squid31/files/patch-configure
index 7f31aa96e0c2..062409040677 100644
--- a/www/squid31/files/patch-configure
+++ b/www/squid31/files/patch-configure
@@ -3,21 +3,19 @@ Patch for Squid bug #2203:
LDFLAGS gets unset when --with-filedescriptors=n is added to
SQUID_CONFIGURE_ARGS.
---- configure.orig Fri Dec 14 01:25:27 2007
-+++ configure Thu Jan 24 19:56:32 2008
-@@ -43934,6 +43934,7 @@
- esac
- { echo "$as_me:$LINENO: result: $SQUID_MAXFD" >&5
- echo "${ECHO_T}$SQUID_MAXFD" >&6; }
-+ LDFLAGS="$TLDFLAGS"
- fi
+--- configure.orig 2008-03-26 21:16:54.000000000 +0100
++++ configure 2008-03-26 21:18:40.000000000 +0100
+@@ -43819,12 +43819,12 @@
- cat >>confdefs.h <<_ACEOF
-@@ -43947,7 +43948,6 @@
- echo " on how to increase your filedescriptor limit"
- sleep 10
- fi
--LDFLAGS="$TLDFLAGS"
-
- if test `expr $SQUID_MAXFD % 64` != 0; then
- echo "WARNING: $SQUID_MAXFD is not an multiple of 64. This may cause issues"
+ { echo "$as_me:$LINENO: checking Maximum number of filedescriptors we can open" >&5
+ echo $ECHO_N "checking Maximum number of filedescriptors we can open... $ECHO_C" >&6; }
++TLDFLAGS="$LDFLAGS"
+ if test -n "$squid_filedescriptors_num" ; then
+ SQUID_MAXFD=$squid_filedescriptors_num
+ { echo "$as_me:$LINENO: result: $SQUID_MAXFD (user-forced)" >&5
+ echo "${ECHO_T}$SQUID_MAXFD (user-forced)" >&6; }
+ else
+- TLDFLAGS="$LDFLAGS"
+ case $host in
+ i386-unknown-freebsd*)
+ if echo "$LDFLAGS" | grep -q pthread; then