aboutsummaryrefslogtreecommitdiff
path: root/www/squid31
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-13 00:21:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-13 00:21:25 +0000
commitc4bc3d86cfdf3e2e1486973d753de4ca45532006 (patch)
tree478860163f4558a1dc39a5bd178079f99c3556e0 /www/squid31
parentf31e9c0cca7d4c5fb57fdadd735b7fcd5456ce78 (diff)
downloadports-c4bc3d86cfdf3e2e1486973d753de4ca45532006.tar.gz
ports-c4bc3d86cfdf3e2e1486973d753de4ca45532006.zip
- Update to 3.1.0.15
- Unbreak ECAP support PR: 141169 Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer)
Notes
Notes: svn path=/head/; revision=245666
Diffstat (limited to 'www/squid31')
-rw-r--r--www/squid31/Makefile14
-rw-r--r--www/squid31/distinfo9
-rw-r--r--www/squid31/files/pkg-install.in2
-rw-r--r--www/squid31/files/squid.in53
4 files changed, 59 insertions, 19 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 8158dcd5bdfe..bbf255e8f88e 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -84,14 +84,14 @@ PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www1.jp.squid-cache.org/%SUBDIR%/ \
http://www1.tw.squid-cache.org/%SUBDIR%/
PATCH_SITE_SUBDIR= Versions/v3/3.1/changesets
-PATCHFILES=
+PATCHFILES= squid-3.1-9822.patch
MAINTAINER= tmseck@web.de
COMMENT= HTTP Caching Proxy (BETA Version)
LATEST_LINK= squid31
-SQUID_BETA_VER= 14
+SQUID_BETA_VER= 15
CONFLICTS= squid-2.[0-9].* squid-3.[^1].* cacheboy-[0-9]*
GNU_CONFIGURE= yes
@@ -110,7 +110,9 @@ PORTEXAMPLES= *
SUB_FILES+= pkg-deinstall pkg-install pkg-message
SUB_LIST+= SQUID_UID=${SQUID_UID} SQUID_GID=${SQUID_GID}
-OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
+OPTIONS= SQUID_KERB_AUTH "Install Kerberos authentication helpers" on \
+ SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
+ SQUID_NIS_AUTH "Install NIS/YP authentication helpers" on \
SQUID_SASL_AUTH "Install SASL authentication helpers" off \
SQUID_IPV6 "Enable IPv6 support" on \
SQUID_DELAY_POOLS "Enable delay pools" off \
@@ -261,7 +263,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
basic_auth+= SASL
libexec+= sasl_auth
.endif
-.if !defined(NO_NIS) && !defined(WITHOUT_NIS)
+# POLA: allow the old global make.conf(5) (pre src.conf(5)) defines, too:
+.if defined(WITH_SQUID_NIS_AUTH) && !defined(NO_NIS) && !defined(WITHOUT_NIS)
basic_auth+= YP
libexec+= yp_auth
.endif
@@ -270,7 +273,8 @@ CONFIGURE_ARGS+= --enable-auth="basic digest negotiate ntlm" \
--enable-digest-auth-helpers="${digest_auth}" \
--enable-external-acl-helpers="${external_acl}" \
--enable-ntlm-auth-helpers="smb_lm"
-.if !defined(NO_KERBEROS) && !defined(WITHOUT_KERBEROS)
+# POLA: allow the old global make.conf(5) (pre src.conf(5)) defines, too:
+.if defined(WITH_SQUID_KERB_AUTH) && !defined(NO_KERBEROS) && !defined(WITHOUT_KERBEROS)
CONFIGURE_ARGS+= --enable-negotiate-auth-helpers="squid_kerb_auth"
libexec+= negotiate_kerb_auth negotiate_kerb_auth_test \
squid_kerb_auth squid_kerb_auth_test
diff --git a/www/squid31/distinfo b/www/squid31/distinfo
index 5b01d373ac6e..e18aa5834c7a 100644
--- a/www/squid31/distinfo
+++ b/www/squid31/distinfo
@@ -1,3 +1,6 @@
-MD5 (squid3.1/squid-3.1.0.14.tar.bz2) = 0e76bc406495b010ac898937e19528c3
-SHA256 (squid3.1/squid-3.1.0.14.tar.bz2) = fb41d1762a48e52f4041b416665f1f9416bf6d1946f3ba3c4e31a74185fcad57
-SIZE (squid3.1/squid-3.1.0.14.tar.bz2) = 2398582
+MD5 (squid3.1/squid-3.1.0.15.tar.bz2) = 295f5c6067244cf8537600be0b9841d7
+SHA256 (squid3.1/squid-3.1.0.15.tar.bz2) = 9fd3d7f5e2bee836126ab0f9cc07fb61207027bed29a3213db73aed46a888bdd
+SIZE (squid3.1/squid-3.1.0.15.tar.bz2) = 2416255
+MD5 (squid3.1/squid-3.1-9822.patch) = fa645851b2dfce355e465cbe0e27404d
+SHA256 (squid3.1/squid-3.1-9822.patch) = 8ffb28e5e6d1adb7e289390fa3dfb99aea989bd65513a1350f84905486819b72
+SIZE (squid3.1/squid-3.1-9822.patch) = 1383
diff --git a/www/squid31/files/pkg-install.in b/www/squid31/files/pkg-install.in
index a244e2e2dd58..1a8391765789 100644
--- a/www/squid31/files/pkg-install.in
+++ b/www/squid31/files/pkg-install.in
@@ -72,7 +72,7 @@ PRE-INSTALL)
if [ ! -d ${squid_confdir} ]; then
echo "Creating ${squid_confdir}..."
install -d -o root -g ${squid_group} \
- -m 0750 ${squid_confdir}
+ -m 0755 ${squid_confdir}
fi
;;
POST-INSTALL)
diff --git a/www/squid31/files/squid.in b/www/squid31/files/squid.in
index 2b39eaef5d3c..a42c41c85073 100644
--- a/www/squid31/files/squid.in
+++ b/www/squid31/files/squid.in
@@ -8,16 +8,51 @@
#
# Note:
# Set "squid_enable=yes" in either /etc/rc.conf, /etc/rc.conf.local or
-# /etc/rc.conf.d/squid to make this script actually do something. There
-# you can also set squid_chdir, squid_pidfile, squid_user, and squid_flags.
+# /etc/rc.conf.d/squid to activate Squid.
#
-# Please see squid(8), rc.conf(5) and rc(8) for further details.
+# Additional variables you can define in one of these files:
+#
+# squid_chdir: the directory into which the rc system moves into before
+# starting Squid. Default: %%PREFIX%%/squid
+#
+# squid_conf: The configuration file that Squid should use.
+# Default: %%PREFIX%%/etc/squid/squid.conf
+#
+# squid_fib: The alternative routing table id that Squid should use.
+# Default: none
+# See setfib(1) for further details. Note that the setfib(2)
+# system call is not available in FreeBSD versions prior to 7.1.
+#
+# squid_user: The user id that should be used to run the Squid master
+# process. Default: %%SQUID_UID%%.
+# Note that you probably need to define "squid_user=root" if
+# you want to run Squid in reverse proxy setups or if you want
+# Squid to listen on a "privileged" port < 1024.
+#
+# squid_pidfile:
+# The name (including the full path) of the Squid
+# master process' PID file.
+# Default: %%PREFIX%%/squid/squid.pid.
+# You only need to change this if you changed the
+# corresponding entry in your Squid configuration.
+#
+# squid_flags: Additional commandline arguments for Squid you might want to
+# use. See squid(8) for further details.
#
squid_checkrunning() {
${command} ${squid_flags} -k check 2>/dev/null
}
+squid_setfib() {
+ sysctl net.fibs >/dev/null 2>&1 || return 0
+ if [ "x${squid_fib}" != "xNONE" ]; then
+ command="setfib -F ${squid_fib} ${command}"
+ else
+ return 0
+ fi
+}
+
squid_stop() {
echo "Stopping ${name}."
${command} ${squid_flags} -k shutdown
@@ -32,28 +67,26 @@ rcvar=${name}_enable
command=%%PREFIX%%/sbin/squid
extra_commands=reload
reload_cmd="${command} ${squid_flags} -k reconfigure"
+start_precmd="squid_setfib"
stop_precmd="squid_checkrunning"
stop_cmd="squid_stop"
load_rc_config ${name}
squid_chdir=${squid_chdir:-"%%PREFIX%%/squid"}
+squid_conf=${squid_conf:-"%%PREFIX%%/etc/squid/squid.conf"}
squid_enable=${squid_enable:-"NO"}
+squid_fib=${squid_fib:-"NONE"}
squid_pidfile=${squid_pidfile:-"%%PREFIX%%/squid/squid.pid"}
squid_user=${squid_user:-%%SQUID_UID%%}
-default_config=%%PREFIX%%/etc/squid/squid.conf
pidfile=${squid_pidfile}
required_dirs=${squid_chdir}
-# squid(8) will not start if ${default_config} is not present so try
+# squid(8) will not start if ${squid_conf} is not present so try
# to catch that beforehand via ${required_files} rather than make
# squid(8) crash.
-# If you remove the default configuration file make sure to add
-# '-f /path/to/your/squid.conf' to squid_flags
-if [ -z "${squid_flags}" ]; then
- required_files=${default_config}
-fi
+required_files=${squid_conf}
run_rc_command "$1"